Keep Alive Session

Locked
afreireich
Posts: 2
Joined: Wed Jul 06, 2011 7:30 pm

Keep Alive Session

Post by afreireich » Wed Jul 06, 2011 7:43 pm

On the 64 bit client of SmartFTP Pro,Utimate there is no place to set a keep alive command. When looking at the keep alive settings page the options bar and interval are displayed and can be set however, the 2nd half of the page, where you can enter the keep alive command (ie: LIST), is blank. I see no other setting that would allow me to set this command. I have tried it with global settings and individual favorites settings. Please advise.

I am running Windows 7 Ultimate 64bit on a multi-core system.
Last edited by afreireich on Wed Jul 06, 2011 7:45 pm, edited 1 time in total.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Keep Alive Session

Post by mb » Wed Jul 06, 2011 8:35 pm

The custom keep alive commands for FTP connections have been removed. A predefined set of commands are now used. If you want to periodically refresh the view there is a new setting in the global settings in the Navigation dialog.
Last edited by mb on Fri Jul 08, 2011 10:09 am, edited 1 time in total.

afreireich
Posts: 2
Joined: Wed Jul 06, 2011 7:30 pm

Re: Keep Alive Session

Post by afreireich » Thu Jul 07, 2011 12:44 pm

This will indeed refresh the folders view but I need to keep the session, as identified in the log window, alive during periods of inactivity or large file transfers. The remote server sees both these examples as inactivity and closes the session after a few minutes aborting the file transfer. Please advise.
Last edited by afreireich on Thu Jul 07, 2011 12:45 pm, edited 1 time in total.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Keep Alive Session

Post by mb » Fri Jul 08, 2011 6:56 am

The browser (remote Browser) and transfer queue connections are independent. There is no need to keep the browser connection alive when doing large transfers.

Locked