SFTP over SSH connect, but not show anything

Locked
Marc0
Posts: 4
Joined: Wed Jun 08, 2011 9:15 am

SFTP over SSH connect, but not show anything

Post by Marc0 » Wed Jun 08, 2011 9:37 am

Hello,

under build 4.0.1180 everything works fine,
but since i have updated to 1188 and today 1190 the server connect (with SFTP over SSH), but do not list anything (Screenshot)

FTP-Connections to other servers works fine, also a Terminal-conncetion

Can i somewhere download the old build (if any method is outdatet) - or can you fix it anyway?

Code: Select all

+- System -----------------------------

Microsoft Windows Vista Ultimate Edition 

Service Pack 2 (Build 6002)



CPU Speed           : 2500 MHz

Total Memory        : 3963 MB

Free Memory         : 1807 MB



+- SmartFTP ---------------------------

Version             : 4.0.1190.0

Time Stamp          : 2011-06-08 00:52:09

Platform            : x64

Id                  : 400062974

Maintenance         : 2012-02-02

Days in use         : 1085



+- Language ---------------------------

en-US



+- Internet Explorer ------------------

Version             : 9.0.8112.16421


Thanks
Mk0

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SFTP over SSH connect, but not show anything

Post by mb » Wed Jun 08, 2011 6:52 pm

Try this:
https://www.smartftp.com/support/kb/how- ... f2625.html

Instead of deleting the key you can rename the key.

Marc0
Posts: 4
Joined: Wed Jun 08, 2011 9:15 am

Re: SFTP over SSH connect, but not show anything

Post by Marc0 » Wed Jun 08, 2011 7:13 pm

this set the Software to defaults - but change nothing on the problem

i think the final "list directory" is already missing

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SFTP over SSH connect, but not show anything

Post by mb » Wed Jun 08, 2011 8:04 pm

I'm unable to reproduce the problem on our test systems here. Did you try it with a different SFTP server? And on a different system?

Marc0
Posts: 4
Joined: Wed Jun 08, 2011 9:15 am

Re: SFTP over SSH connect, but not show anything

Post by Marc0 » Wed Jun 08, 2011 8:39 pm

i test it on a Win7 System -> the same problem

i have no similar server for test this

but over filehistory of the installfiles i got now the 1180 build and install that - now it works very well

now the last log is

Code: Select all

[22:31:01] Directory listing complete.
that message was missing on the newer builds
Last edited by Marc0 on Wed Jun 08, 2011 8:42 pm, edited 1 time in total.

Marc0
Posts: 4
Joined: Wed Jun 08, 2011 9:15 am

Re: SFTP over SSH connect, but not show anything

Post by Marc0 » Thu Jun 09, 2011 12:16 pm


mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SFTP over SSH connect, but not show anything

Post by mb » Thu Jun 09, 2011 12:42 pm

I turned out that this is actually a bug in all versions of openssh that has been triggered by a corrupt configuration option in a favorite. I have filed a bug report for openssh: https://bugzilla.mindrot.org/show_bug.cgi?id=1913

Locked