FTP/SSL in Active Mode connections

Locked
mantovani
Posts: 3
Joined: Tue Aug 26, 2003 5:45 pm

FTP/SSL in Active Mode connections

Post by mantovani » Tue Aug 26, 2003 5:59 pm

Simply: ACTIVE (PORT) worked with build 976, it does not work anymore with build 978.

With 976:
PROT P
200 Prot set to P
PORT 192,168,0,1,16,66
200 Port command successful
Opening data connection IP: 192.168.0.1 PORT: 4162.
LIST -aL
150 Opening ASCII SSL data connection for directory list
Connected. Exchanging encryption keys...
Session Cipher: 128 bit RC4
SSL encrypted session established.
57 bytes received successfully. (57 B/s) (00:00:01).
226 Transfer complete

With 978:
PROT P
200 Prot set to P
PORT 192,168,0,1,16,83
200 Port command successful
Opening data connection IP: 192.168.0.1 PORT: 4179.
LIST -aL
150 Opening ASCII SSL data connection for directory list
0 bytes received successfully. (0 B/s) (00:00:01).
425 Can't open data connection

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: FTP/SSL in Active Mode connections

Post by mb » Wed Aug 27, 2003 12:48 am

Do you run both versions of SmartFTP in parallel?

-Mat

mantovani
Posts: 3
Joined: Tue Aug 26, 2003 5:45 pm

Re: FTP/SSL in Active Mode connections

Post by mantovani » Wed Aug 27, 2003 9:29 am

Hi Mat,
no, I don't.

Before trying each version I uninstall the previous one from control panel -> add/remove programs.

I'm using W2000 sp4 ITalian.

I dowloaded 978 from your website for evaluation (a friend told me to try a nice ftp program ), installed it, but it didn't work with ACTIVE (PORT) SSL explicit connections.
My friend told me that he was not having problems, so we checked the version and we found he was using 976.
So I tried 976 after uninstalling 978, and actually 976 works.

I thought useful to report it to you.

May I help you in some other way?

Leo

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: FTP/SSL in Active Mode connections

Post by mb » Fri Aug 29, 2003 12:40 am

The bug has been fixed in the latest developer build:
https://www.smartftp.com/download

Thanks for your time.

mantovani
Posts: 3
Joined: Tue Aug 26, 2003 5:45 pm

Re: FTP/SSL in Active Mode connections

Post by mantovani » Mon Sep 01, 2003 6:48 pm

Hi Mat,
I confirm you that it works.

Really nice ftp program, however it seems to me that it's missing the possibility to save options/settings individually for each site, which is in my opinion a must for a ftp program.
Or may be I overlooked it

Leo

Louie
Posts: 337
Joined: Wed Sep 19, 2001 10:00 pm

Re: FTP/SSL in Active Mode connections

Post by Louie » Mon Sep 01, 2003 8:59 pm

Hi Mat,
I confirm you that it works.

Really nice ftp program, however it seems to me that it's missing the possibility to save options/settings individually for each site, which is in my opinion a must for a ftp program.
Or may be I overlooked it

Leo

1. Thank you for confirming the bug fix.

2. Each site can have there own setting, by adding the site to your favorites.
Then simply edit the favorite site, and customize the favorite to your desire.

Locked