Remote editor settings not working properly II

Locked
clarisa
Posts: 1
Joined: Sun Oct 14, 2007 1:10 pm

Remote editor settings not working properly II

Post by clarisa » Sun Oct 14, 2007 1:30 pm

Hello.

Ok, I know theres a similar topic like this before but my problem is different.

So, I was using SmartFTP for about 3 months now, and just recently I encountered a problem.

I was about to edit (I just right click >> edit) my .php files for my website, normally, it opens Notepad (my default .php editor, where I edit my .php files). But a while ago when I was doing that, the Notepad won't open. I right click >> edit the .php several times but the notepad won't open, it's just the remote edit (the one that lets you hit upload when its modified). I thought there's just something wrong so I decided to run SmartFTP agan but nothing happened. I tried installing the new version which is the 2.5 but nothing happened as well, the Notepad won't really open.

I really don't know what to do now. Please help.

You can email me at clrz_dirtbag@goingdead.net or posting a reply here on my post. Thank You.
Last edited by clarisa on Sun Oct 14, 2007 1:56 pm, edited 1 time in total.

robix
Posts: 2
Joined: Thu Oct 18, 2007 1:03 pm

Re: Remote editor settings not working properly II

Post by robix » Thu Oct 18, 2007 1:21 pm

I experience the same issue.

The file is downloaded, but the associated application is not started.

DivineAnarchy
Posts: 2
Joined: Thu Oct 18, 2007 7:54 pm

Re: Remote editor settings not working properly II

Post by DivineAnarchy » Thu Oct 18, 2007 7:59 pm

Yep, I've been using SmartFTP for years w/o this problem, so I'm assuming its related to my new Vista install. The VIEW option works however, so I'm investigating the registry to find a manual fix.

DivineAnarchy
Posts: 2
Joined: Thu Oct 18, 2007 7:54 pm

Re: Remote editor settings not working properly II

Post by DivineAnarchy » Thu Oct 18, 2007 8:08 pm

Ok its not a bug- but SmartFTP should manifest the "unknown file extension" dialog if the filetype isn't recognized by windows (currently nothing happens).

By default under Remote Edit options, it has "Windows File Association" selected to edit with.

If you're used to the old style of SmartFTP- you can change it to "Same as Viewer" (which is set under General).

Note: I'm using Vista
Last edited by DivineAnarchy on Thu Oct 18, 2007 8:09 pm, edited 1 time in total.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote editor settings not working properly II

Post by mb » Thu Oct 18, 2007 9:56 pm

I have implemented a fallback in the latest version: if there is no file association it will use the default viewer.
Latest version:
https://www.smartftp.com/download

Regards,
Mat

robix
Posts: 2
Joined: Thu Oct 18, 2007 1:03 pm

Re: Remote editor settings not working properly II

Post by robix » Fri Oct 19, 2007 10:38 am


Locked