Remote editor settings not working properly

Locked
bfarber
Posts: 4
Joined: Mon Oct 01, 2007 4:00 pm

Remote editor settings not working properly

Post by bfarber » Mon Oct 01, 2007 4:08 pm

SmartFTP suddenly failed to open starting today, so I decided to just go ahead and update it. Downloaded 2.5.1006.46 (latest version from the main download page) and installed. So far so good.

I login to an FTP site and right click -> Edit on a .php file as I normally do, and it opens in Notepad, which is not my .php file editor.

I've found the following so far

1) In Windows (Tools -> Folder options -> File Types) I have "Crimson Editor" set as my .php file editor. If I set SmartFTP under General -> Remote Edit "by default use" to "Windows Default Association" this selection is NOT honored, and instead Notepad is launched.

2) If I set it to "File Viewer configured in General page" (and yes, Crimson Editor is mapped there properly) it launched a Windows explorer process viewing the Crimson Editor folder (rather than the application itself). After restarting SmartFTP it is now launching the SmartFTP2.0 folder instead.

3) If I manually add file types under the Remote Edit tab, it changes nothing under either configuration.


Right clicking and choosing "View" works fine, but editing the file and saving does not allow me to (easily) reupload the file.


I use SmartFTP for basic FTP, but the ability to right click -> edit, make changes, save, and hit upload is an important feature to me.

(If this should be moved to support - i.e. you find it to not be a bug, please accept my apologies and feel free to move it - I did a search in both forums and didn't come across anything recent that seemed relevant).

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote editor settings not working properly

Post by mb » Mon Oct 01, 2007 4:41 pm

Hello ..

Thank you for your bug report.

1)
I'm unable to reproduce this. SmartFTP opens the executable which is also called if you right click on a file in the Windows Explorer and select "Edit" from the context menu.

2)
Bug confirmed and fixed in .47.

3)
I'm unable to reproduce this as well. What extension did you add? In your case it would be:
.php -> Crimson Editor

Regards,
Mat

bfarber
Posts: 4
Joined: Mon Oct 01, 2007 4:00 pm

Re: Remote editor settings not working properly

Post by bfarber » Mon Oct 01, 2007 6:03 pm

Re #1
Well, that is interesting. When I right click the file and choose edit, it's opening in Notepad as well (although if I simply doubleclick the file it opens in my custom editor). Let's disregard this report for now and assume it's some bad mapping on my system.

#2 - great to hear

Re #3
It looks like this was my mistake. When I had configured this previously, I believe I used a comma instead of a semi-colon to test the file types.

I tried with just .php (and with .php;.htaccess) and this is working. This allows me to continue using it in the same capacity as before the update at least, so thanks for this.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Remote editor settings not working properly

Post by mb » Mon Oct 01, 2007 6:29 pm

The new version is up in case you want to test it.

Regards,
Mat

bfarber
Posts: 4
Joined: Mon Oct 01, 2007 4:00 pm

Re: Remote editor settings not working properly

Post by bfarber » Mon Oct 01, 2007 8:00 pm

Yup, seems to be good now even with removing the custom filetype handlers.

Thanks!

Locked