Desktop.ini in smartftp folder causing files to be hidden

Locked
Packet1009
Posts: 7
Joined: Mon Jul 23, 2007 12:41 am

Desktop.ini in smartftp folder causing files to be hidden

Post by Packet1009 » Mon Jul 23, 2007 12:50 am

I've just started noticing this with the past couple of versions.

Couldnt find any mention of it on searching for desktop.ini, so here's my hopefully non-duplicated bug report:


Problem: Cannot browse the Smartftp install folder with Windows Explorer - No files are shown.
Properties on folder show the correct size and # of files, but no files are displayed.
The Command prompt will show all files correctly.
Also, cannot manipulate folder due to the usual right click menu options being unavailable.

I finally figured out that it was due to desktop.ini being created on install (and later, upon running the Smartftp application)

Contents of said file:
[.ShellClassInfo]
CLSID={39DD67E0-73B6-4a11-AF55-49E1EBBF72BE}

Deleting the desktop.ini file from the Smartftp folder fixes the issue, however, it returns upon launching the application again.

My workaround has been to remove all the content in the desktop.ini file and mark it as +RSH (read-only, system, hidden). I figure just read-only may work as well, short of using ntfs permissions.

Once the desktop.ini info is removed, I can browse the folder through Windows Explorer again.

system specs as below from Smartftp's 'system info'

+- System -----------------------------
Microsoft Windows 2000 Professional
Service Pack 4 (Build 2195)

CPU Speed : 1992 MHz
Total Memory : 1023 MB
Free Memory : 653 MB

+- SmartFTP ---------------------------
Version : 2.5.1006.4
Time Stamp : 2007-06-08 18:41:59
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.9.24
sfFavorites.dll : 1.0.2.4
SmartHook.dll : 1.0.2.2

+- Language ---------------------------
SmartFTP.exe : 2.5.1006.4

+- Internet Explorer ------------------
Version : 6.0.2800.1106

+- Winsock ----------------------------
Winsock : 2.2

thanks in advance
Last edited by Packet1009 on Mon Jul 23, 2007 12:51 am, edited 1 time in total.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Desktop.ini in smartftp folder causing files to be hidden

Post by mb » Mon Jul 23, 2007 2:52 am

Hello ..

The desktop.ini is only created in the favorites folder (Settings -> Favorites). In your case the personal favorites folder has been set to to the application folder or the application folder has been added to the additional favorites folders in the favorite settings. This can either happen manually or the favorites folder has been set to the application folder in a previous version of SmartFTP.

To avoid the problem in the future please make sure that the personal favorites folder doesn't point to the application folder.

Regards,
-Mat
SmartFTP

Packet1009
Posts: 7
Joined: Mon Jul 23, 2007 12:41 am

Re: Desktop.ini in smartftp folder causing files to be hidden

Post by Packet1009 » Thu Aug 02, 2007 10:22 am

Hi,

Thanks for the info - I tried what you said and moved the Favorites to a new folder. However, I see similar behaviour even in the "favorites" folder.

The clsid within the desktop.ini in the favorites folder causes the folder to not display its contents in windows explorer.

Is this by design?
Last edited by Packet1009 on Thu Aug 02, 2007 10:23 am, edited 1 time in total.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Desktop.ini in smartftp folder causing files to be hidden

Post by mb » Fri Aug 03, 2007 1:31 am

Hello ...

The folder shouldn't be empty in Windows Explorer. I have the same problem here and we will look into it.

Regards,
-Mat

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Desktop.ini in smartftp folder causing files to be hidden

Post by mb » Sat Aug 04, 2007 2:08 am

Hello ..

Bug fixed in the latest version (.16):
https://www.smartftp.com/download
or
https://www.smartftp.com/download

Regards,
-Mat

Packet1009
Posts: 7
Joined: Mon Jul 23, 2007 12:41 am

Re: Desktop.ini in smartftp folder causing files to be hidden

Post by Packet1009 » Sat Aug 04, 2007 12:27 pm

that's such a quick fix - thanks very much

Locked