Cache not working

Locked
rlevis
Posts: 14
Joined: Mon Jul 09, 2007 11:37 am

Cache not working

Post by rlevis » Mon Jul 09, 2007 12:29 pm

I'm using the latest version 2.5.1006. Just upgraded now from 1005 to see if this would fix the problem, but it doesn't. It use to work fine in an older version, but since upgrading to 2.5, SmartFTP will not cache the files and directories on my website FTP server. If I click a folder it completely rereads the files in the folder. Click another folder and then back to the same folder, and it again rereads the files from scratch. This takes 20 seconds on a folder containing many files.

Restarting SmartFTP and it again connects to the server and rereads the main folder every time.

I have the Enable Cache checked in the Settings, and set to expire after 28 days. I've tried emptying the cache. It's been bugging me for several weeks.

Another FTP site that I frequent works fine and caches correctly. Any ideas?

Thanks,
Ross.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Cache not working

Post by mb » Mon Jul 09, 2007 4:34 pm

Please try it again with the latest version (.8):
https://www.smartftp.com/download
or
https://www.smartftp.com/download

-Mat
Last edited by mb on Mon Jul 09, 2007 6:29 pm, edited 1 time in total.

rlevis
Posts: 14
Joined: Mon Jul 09, 2007 11:37 am

Re: Cache not working

Post by rlevis » Tue Jul 10, 2007 1:36 am

I'm sorry to say that doesn't work either.

Just another clue perhaps. I notice that the folders I visit do not go bold like they use to. Folders that were viewed and loaded in the cache should go bold. It's as if the cache system is disabled for this one site. But I don't think that is possible, is it?

Regards,
Ross.
Last edited by rlevis on Tue Jul 10, 2007 1:38 am, edited 1 time in total.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Cache not working

Post by mb » Tue Jul 10, 2007 3:14 am

Hello ...

If Remote Browsers get restored when you start SmartFTP you need to navigate to the root folder first before the cache gets activated.
This is a small problem which will be fixed in a future version.

Regards,
SmartFTP

rlevis
Posts: 14
Joined: Mon Jul 09, 2007 11:37 am

Re: Cache not working

Post by rlevis » Tue Jul 10, 2007 7:36 am

Aha. A light just came on. It wasn't the upgrade to a new version when the problem started. My web hosting company changed the driver letter from C to E. It was after this the problem started.

The full path to my root folder is like this.
/e:/hosting/member/my name

Clicking on the e: or "hosting" folder produces a Permission Denied error. Is this why it can't cache the folders?
It was working when it was/c:/hosting/...

Regards,
Ross.

mb
Posts: 12030
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Cache not working

Post by mb » Wed Jul 11, 2007 4:54 am

Hello ..

Please give the latest version a try:
https://www.smartftp.com/download

It should definitively fix the problem now.

Thanks
-Mat

Locked