SmartFTP seit Win10 fürchterlich langsam

This forum is not monitored by the SmartFTP staff. To contact technical support see KB: How to request technical support.
Post Reply
edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Sat Feb 20, 2016 6:23 pm

Hallo zusammen,
 
ich weiß nicht genau, wie ich es schreiben soll, der Titel stimmt nicht ganz.
 
Ich nutze SmartFTP nun schon sicherlich seit 7 oder 8 Jahren und war immer top zufrieden. Win10 nutze ich direkt wenige Tage nach dem Erscheinen, damals noch mit einem nicht angepassten SmartFTP, also auch noch mit dem alten Layout. Das funktionierte auch noch alles bestens.
 
Doch seit SmartFTP nun dieses neue Layout hat (primär weiß), bekomme ich beim Übertragen von Daten oder Löschen von Daten auf dem Server immer so ein Fenster:
 
Ok, das BIld einfügen geht nicht ("You are not allowed to use that image extension on this community.").
Hier ein Link zu: https://seo-nw.de/filedata/fetch?id=103 ... &type=full
 
Wie gesagt, beim Übertragen, aber auch beim Löschen. Das Problem ist, dass dieses Fenster ewig da steht, bevor der eigentliche Vorgang überhaupt startet. Ich versuche so z.B. aktuell seit 27 Minuten die Software "Piwik" vom Server zu löschen und der ist noch immer nicht fertig. Das dauerte normalerweise keine 60 Sekunden. Die Übertragung dann dauert weit über eine Stunde, wobei nur in den letzten 4-5 Minuten überhaupt Daten übertragen werden, vorher steht einfach dieses Fenster da und tut irgendwas. Die Zeitangaben kann man in dem Fenster auch knicken, denn bei jedem neuen Ordner ändern die sich schlagartig.
 
Hat einer eine Idee was ich machen kann? So ist SmartFTP für mich leider komplett unbrauchbar geworden :(
 
Danke und Gruß,
Ingo

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SmartFTP seit Win10 fürchterlich langsam

Post by mb » Sat Feb 20, 2016 7:26 pm

Der link funktioniert nicht. Eventuell auf zippyshare oder so uploaden.
 
Versuch sonst:
- menu: File - Settings
- Dann im General - Navigation dialog
- In der Remote browser gruppe
  das Delete von Browser auf Queue aendern.
 
 
Ansonsten hilft auch Support weiter:
menu:  File - Help - Request Support
Last edited by mb on Sat Feb 20, 2016 7:37 pm, edited 1 time in total.

edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

Re: SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Sun Feb 21, 2016 12:11 pm

Ah, ok, mist. Hatte nicht bedacht, dass man in dem Forum, wo das Bild ist, angemeldet sein muss um das Bild zu sehen.
 
Das hier ist vom Löschvorgang:
http://1nt.de/smartftp.jpg
 
Und das vom Upload:
http://1nt.de/smartftp-upload.jpg
 
Wie gesagt, alle Zahlenwerte auf dem Bild kann man knicken, die ändern sich ständig in alle Richtungen.
 
Mir kommt das so vor, als ob der da vorab einen Abgleich mit Quelle und Ziel macht oder so in der Art, also die Files prüft.
 
Was auch gerne mal kommt, egal Upload oder Löschen, dass ganz am Ende (aber noch vor der eigentlichen Ausführung) dann die Aufforderung zu Windows-Admin-Rechten kommt. Was will der denn mit Adminrechten von Windows, wenn auf dem Linux-Server irgendeine Berechtigung nicht passt? Kann man dann auch erteilen und "fortsetzen", dann bricht er aber mit einem Fehler ab. "Überspringt" man, dann beginnt in der Regel eine "Neuberechnung", die genauso lange dauert wie vorher.
 
Deine genannten Punkte werde ich mal versuchen.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SmartFTP seit Win10 fürchterlich langsam

Post by mb » Sun Feb 21, 2016 1:02 pm

>Delete
Siehe Loesung in letzter Antwort
 
>UP=pload
Folder mit den files uploaden (und nicht 1000 files selektieren) und dann beim file exist dialog "Use automatic rules" verwenden.
Last edited by mb on Sun Feb 21, 2016 1:02 pm, edited 1 time in total.

edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

Re: SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Sun Feb 21, 2016 1:25 pm

ok, muss ich mal versuchen. Aber. Ich lade immer ganze Ordner hoch und nie einzelne Files. Im Beispiel Piwik eben den ganzen Ordner "Piwik", der aus zig Unterordnern und tausenden von Dateien besteht. Genau deswegen ist dieses "Fenster" mit seinen Angaben ja auch so ungenau. Da werden z.B. 60 Dateien als "verbleibende Elemente" gezählt und Restdauer berechnet, dann kommt der nächste Unterordner, dann sind es plötzlich z.B. 700 Dateien und eine Restdauer, die 5x so lang ist wie vorher usw. Das geht so lange, bis alle Ordner und Dateien durch sind, dann erst beginnt die Übertragung.
 
Früher habe ich den Ordner einfach rübergeschoben (von Lokal nach public_html), die Files erschienen sofort in der Warteschlange und es ging los. Jetzt kommt erst das Fenster, dann die Warteschlange, dann die Übertragung.
Last edited by edvsb on Sun Feb 21, 2016 1:29 pm, edited 1 time in total.

edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

Re: SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Sun Feb 21, 2016 2:38 pm

Hi mb, vielen Dank erst mal, bin nun einen großen Schritt weiter :)
 
Wenn ich Daten über andere kopiere, also nicht vorher lösche, dann wählte ich immer (also die letzten 8 Jahre) Ordner "Zusammenführen" und Dateien "ersetzen". Genau dort kommt dann dieses besagte Fenster. Wähle ich aber, so wie Du schreibst, die automatischen Regeln, dann startet der Upload sofort, es kommt kein Fenster.
 
Also, bisher, seit ich das Problem habe, Piwik drüber kopieren = fast eine Stunde
Nach Deinem Weg: knapp 5 Minuten
 
Nur, kann ich irgendwie sehen, was diese "automatischen Regeln" genau sind? Ich meine, der muss alles ersetzen und darf da nicht selbst was "überspringen" oder so. Ist das gewährleistet über diesen Weg?

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SmartFTP seit Win10 fürchterlich langsam

Post by mb » Sun Feb 21, 2016 6:45 pm

Die Regeln kannst du zwar aendern, solltest du aber nicht. SmartFTP macht das eigentlich immer korrekt.

edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

Re: SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Wed May 18, 2016 9:52 am

Muss mich leider noch mal deswegen melden. War eben wieder dabei, eine neue Version von Piwik auf den Server zu schieben.... Diesmal mit Deiner Option, also den automatischen Regeln. Das ging schnell, keine Frage, ca. 5 Minuten. Allerdings hat es mir die Installation komplett zerschossen, denn es wurden anscheinend nicht alle Dateien überschrieben. Einige blieben auf dem alten Stand.
 
Also das ganze nochmal nach der bisherigen Methode mit Zusammenführen und Überschreiben. Danach lief die Installation zwar wieder, aber es dauerte wieder über 30 Minuten. 25 Minuten davon dieses "neue Fenster" vor der eigentlichen Übertragung, wo zwar steht "kopiere", auch irgendein Netzwerkverkehr stattfindet, aber in Wirklichkeit gar nicht kopiert wird. Erst wenn das weg ist kommt die normale Übertragung und die ist dann in 5 Min wieder durch.
 
Sorry, ich komme mit dem SmartFTP leider so gar nicht mehr zurecht.... Mich graut es schon, wenn ich mal einen Ordner mit 100.000 Files hochschieben muss, in dem von Piwik sind ja nur "7000" Files :(
 
Danke und Gruß,
Ingo

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: SmartFTP seit Win10 fürchterlich langsam

Post by mb » Wed May 18, 2016 1:27 pm

Den folder uploaden, im ersten File Exist / File Confirmation dialog, "Use automatic rules" auswaehlen.

edvsb
Posts: 6
Joined: Sat Feb 20, 2016 6:14 pm

Re: SmartFTP seit Win10 fürchterlich langsam

Post by edvsb » Wed May 18, 2016 2:02 pm

Hallo mb,
 
das hatte ich so gemacht beim ersten Versuch. Danach waren aber nicht alle Dateien überschrieben und Piwik lief nicht mehr. Hatte dann per Hand 7 Dateien gefunden, die nicht überschrieben wurden und zwei, die nur teilweise übertragen wurden (Script war einfach mitten im File abgeschnitten, im Original aber nicht). Also manuell hochgeladen, brachte aber nichts, da waren noch mehr. Also habe ich es dann wieder auf den normalen Weg hochgeladen und dann ging es wieder, halt fürchterlich langsam.
 
Ich verstehe es einfach nicht, irgendwas muss ja passiert sein. Seit SmartFTP das neue Design hat und an Win10 angepasst wurde zickt es rum. Dieses "fürchterlich langsam" ist aber nicht nur bei SmartFTP so, sondern bei allen Dateioperationen, egal welches Programm, wenn es mehrere Dateien sind. Hatte vorhin z.B. mal das Log aktiviert. Im Ordner "Transfer Queue" waren dann 6000 Dateien drinnen. Um die zu löschen brauchte ich fast 15 Minuten, 13 davon der Dialog. (Also 13 Minuten um zu berechnen, wie lange das Löschen dauern wird, um dann binnen 2 Minuten zu löschen) Mir ist schon klar, dass das irgendwo an Win10 liegt, aber bis zur Design-Änderungen war der Dialog bei SmartFTP halt nicht, bei den anderen Programmen schon. Bei SmartFTP kam es dann hinterher.
 
Schiebe ich z.B. drei Ordner einzeln hoch, dann kommt dieser "berechne Restdauer"-Dialog nicht. In den drei Ordnern sind jeweils wieder ein Ordner und ca. 10 Dateien. Schiebe ich den übergeordneten Ordner hoch, in dem genau diese drei Ordner sind und nichts anderes, dann ist der Dialog wieder da. Scheint so, als ob es da irgendwie einen Schwellenwert gibt, ab dem der kommt. Nutze ich den Weg von Dir, also die automatischen Regeln, dann kommt er auch nicht. Irgendwas muss den ja also auslösen. Nur wie gesagt, die automatischen Regeln hatten irgendwas verbockt.
 
Und beim entpacken genauso, egal ob 7zip oder winrar. Früher machte ich das Archive auf und schob es direkt in den lokalen Ordner von SmartFTP. Das kann ich jetzt auch knicken, denn dann ist der auch gut 10 Minuten zum Entpacken und 16 MB beschäftigt und die CPU hängt irgendwo bei 95%. Wobei der da ja nicht wirklich entpackt, sondern..... Entpackt in wenigen Sekunden, aber nicht in den lokalen Ordner, sondern nach User/Temp. Dann geht SmartFTP auf "Keine Rückmeldung" und "Server ausgelastet - wechseln zu". Klicke ich das an, dann kommt wieder der "Berechnen-Dialog", läuft ewig durch und dann erst kopiert der überhaupt in den lokalen Zielordner.
 
Hm.....
 
Danke und Gruß,
Ingo

Post Reply