Disable platform update warning and multi-part not working

This forum is not monitored by the SmartFTP staff. To contact technical support see KB: How to request technical support.
Post Reply
awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Disable platform update warning and multi-part not working

Post by awr » Sun Aug 02, 2015 3:34 am

Hi,

I'm evaluating SmartFTP, and I have 2 problems with it:

1) When I start it, it pop-ups a warning about the platform update for Windows 7.

The KB2670838 update that is part of it is buggy. It prevents the resource monitor to work, so I do not want to install it.

As far as as I can see, SmartFTP works without this update. Having this pop-up and the subsequent display of the <broken url> page each time I use SmartFTP is a MAJOR hassle. Can I suppress this warning?

2) I set up the multi-part default value to 16. But for each SFTP transfer I start, it defaults to 2 and I have to manually edit the properties of the transfer to the needed 16 value. That happens even if I override the multi-part setting to 16 for a specific connection. It always starts with 2 instead if 16.
Edit: it seems to work in fact,  it just needs a little while to kick in. Please disregard item 2).

Thanks in advance for any help.
Last edited by awr on Sun Aug 02, 2015 4:02 am, edited 1 time in total.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Disable platform update warning and multi-part not working

Post by mb » Sun Aug 02, 2015 10:54 am

KB2670838 is required for SmartFTP. It is also a prerequisite for IE10 and IE11. Alternatively upgrade to Windows 10 which is a free upgrade.
Last edited by mb on Sun Aug 02, 2015 10:57 am, edited 1 time in total.

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Sun Aug 02, 2015 3:09 pm

mb wrote: KB2670838 is required for SmartFTP. It is also a prerequisite for IE10 and IE11. Alternatively upgrade to Windows 10 which is a free upgrade.
Well, SmartFTP works well without it, and I don't need IE10+.
 
As for W10, I hate it. It's blurry when you use a high DPI setting (which I need with my monitor), and looks generally ugly as sin.
 
So, I guess that there is no way to just disable that warning with SmartFTP? There should be a "do not display this warning anymore" option on the popup dialog...
Last edited by awr on Sun Aug 02, 2015 3:09 pm, edited 1 time in total.

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Sun Aug 02, 2015 3:38 pm

Or maybe I can install the 6.0.2146 version? It seems it does not need this update.
 
Would you have a link for it (the 64 bit version)?

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Sun Aug 02, 2015 6:48 pm

Ok, I decided to forego the Resource Monitor, and replace it with Process Hacker 2.
 
That allows to install the KB2670838 update...
 
Thanks.

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Disable platform update warning and multi-part not working

Post by mb » Mon Aug 03, 2015 12:57 am

Okay :-)
Is there anything Process Hacker 2 does, which Sysinternal's Process Explorer (https://technet.microsoft.com/en-us/sys ... 96653.aspx) doesnt?
Last edited by mb on Mon Aug 03, 2015 12:57 am, edited 1 time in total.

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Mon Aug 03, 2015 2:22 am

mb wrote: Okay :-)
Is there anything Process Hacker 2 does, which Sysinternal's Process Explorer (https://technet.microsoft.com/en-us/sys ... 96653.aspx) doesnt?
 
Unless I missed a setting, showing the filename of the files being accessed by the various processes.
 
I often want to see which processes have the most I/O activity, and what files they are reading or writing. Process Explorer shows a lot of things, but apparently not the filenames.

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Mon Aug 03, 2015 2:30 am

Here is a screenshot of the 2:
 
Image

mb
Posts: 12029
Joined: Thu Oct 11, 2001 1:24 pm
Display name: Mat (SmartFTP)
Contact:

Re: Disable platform update warning and multi-part not working

Post by mb » Mon Aug 03, 2015 5:51 pm

Thanks. But I think you can select the columns if you right-click on the list view header.
 
BTW: Have you seen/applied this hotfix for resource monitor?
https://support.microsoft.com/en-us/kb/2924171
Maybe it applies to your case.
Last edited by mb on Mon Aug 03, 2015 11:27 pm, edited 1 time in total.

awr
Posts: 8
Joined: Sun Aug 02, 2015 3:29 am

Re: Disable platform update warning and multi-part not working

Post by awr » Tue Aug 04, 2015 12:47 pm

mb wrote: Thanks. But I think you can select the columns if you right-click on the list view header.
 
BTW: Have you seen/applied this hotfix for resource monitor?
https://support.microsoft.com/en-us/kb/2924171
Maybe it applies to your case.
Indeed, but I did not find any columns that show the name of the files being read or written on.
 
Thanks for taking the time to forward the hotfix link. Unfortunately, it's for another issue and does not solve mine.
 
This problem has been discussed on the various Microsoft help sites for years, and it seems to be still unsolved.
 
It's no longer a real concern anymore for me, I moved on. :-)

Post Reply