Jump to content


Issue Information

  • #000073

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Filter rules from Default Favourite not reliable

Posted by meisterkaiser on 11 May 2010 - 09:33 AM

the default favourite defines an exclusion filter

WildChar .svn Folder(Name)
WildChar .svn File(Name)

This is working only *most* of the time.
When copying several folders with subdirectories to the remote server, at least one .svn folder from a subdirectory gets copied to the remote machine (maybe the first occurence of a .svn file in a subdirectory).

Tried move the exclusion rule from default to the local favourite, same effect.


+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 2211 MHz
Total Memory : 2047 MB
Free Memory : 1118 MB

+- SmartFTP ---------------------------
Version : 4.0.1110.0
Time Stamp : 2010-05-10 17:45:15
Platform : x86
Id : 400060093
Maintenance : 2011-07-22
Days in use : 1110

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Updating status to: Awaiting Feedback

Please provide step by step instructions on how to reproduce.


meisterkaiser
May 11 2010 09:57 AM
Sorry, I was not clear enough...
the error occurs when merging directories, not on the initial upload.

- select directory with .svn folder inside
- copy directory to remote server
- upload ok
- upload same directory again
- Select 'Merge' in 'Confirm Folder Replace'
- .svn directory will be copied to remote machine

more specific:

- select directory A with subdirecories sub_A, sub_B, sub_C - all of them containing .svn folders
- copy to remote server
- upload ok
- upload same directories again
- select 'Do for all conflicts' & 'Merge' in 'Confirm Folder Replace'
- select 'Do for all conflicts' & 'Copy & Replace' in 'Copy File'
- .svn directory from A and sub_A will be copied to remote server
- .svn directory from sub_B, sub_C are correctly ignored

The filters only apply if you select "Use Automatic Rules" in the file exist dialog. They do not apply for transfers for which you manually choose the action.


meisterkaiser
May 11 2010 10:24 AM
using 'Automatic Rules' an edited file in a subdirectory is NOT copied to the remote server, maybe because the default setting for 'File Exists' is 'Ask' ...
logical loop here? :-)

And of course this behaviour is *very* confusing, especially because the Filter seems to work on other than the first subdirectory when using 'Merge'!

I agree with you. The current implementation has room for improvement.

Updating status to: Confirmed





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users