Jump to content


Issue Information

  • #000052

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

right-click "view" in remote opens folder

Posted by Bubo on 16 March 2010 - 03:08 PM

Right-clicking "view" in the remote browser opens consistently folder C:\Documents and Settings\"username". It does not matter what file type it concerns, be it .txt, .html etc. Vieweing worked in earlier versions perfectly, opning each file with the appropriate program.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 1816 MHz
Total Memory : 1023 MB
Free Memory : 479 MB

+- SmartFTP ---------------------------
Version : 4.0.1086.0
Time Stamp : 2010-03-15 22:12:07
Platform : x86
Id : 400008048
Maintenance : 2012-02-11
Days in use : 603

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 8.0.6001.18702

+- Winsock ----------------------------
Winsock : 2.2

Updating status to: Awaiting Feedback

What is the File Viewer set in the menu: Tools->Settings General dialog?

What is the File Viewer set in the menu: Tools->Settings General dialog?

It is set to "C:\Program Files\NoteTab Pro\NotePro.exe".
Tried also with good old C:\Windows\Notepad.exe - same result.

Try to uninstall SmartFTP and then install the latest version. I know it's the same advice as in the other bug report.
Oh an most important, do not forget to reboot if you are asked to.

Did a complete and fresh reinstall.
Unfortunately, still no viewing possible, right-clicking "view" in the remote browser keeps opning the folder "C:\Documents and Settings\username" ...

I hope you have a new suggestion?

Kindest,
Bubo.

Can you post the full path of C:\Documents and Settings\username ...
Thanks

Of course, the folder that by default gets opened is "C:\Documents and Settings\Administrator".


Kindest,
Bubo

PS Don't you ever sleep ? :rolleyes:

Try this:
1. Stop the transfer queue
2. Right-click on file you want to view in the Remote Browser. Select View
3. A new item is added to the transfer queue
4. Go to the transfer queue item properties.
5. Post the full source path here

Thanks again
Mat

Full source: /robots.txt
full destination: D:\Temp\ab98a8ab\robots.txt

Just an example of any file, no quotes around it. BTW, the file IS actually downloaded to that Temp Dir after I start the queue and immediately after that the folder as mentioned above is opened.

Thank you.

Can you try it under a different user account on this system?

Can you try it under a different user account on this system?

There is no other user on this particular PC, and never has been.

Some additional info: in 4.0.1087.0 the problem persists; my earlier installed version was 4.0.1071.0. So somewhere between these two versions the problem must have been introduced.
Hope this helps a little bit ...

Kindest,
Bubo.

Thanks. Can you create a new user account on the system and then try it under this user account?

Thanks
Mat

Thanks. Can you create a new user account on the system and then try it under this user account?

Created a brand new user - here nothing happens when clicking "view".
Meaning: the file to view gets downloaded allright to the temp folder, but now instead of opening a folder after that, simply nothing happens.

One other noteworthy observation: with both users, the "edit" function works fine! It gets downloaded (again to the tempdir), and after that the appropriate program to edit the file is launched (remote editor setting in options: Editors, Shell Default Association).
A setting like that is missing for viewing a file, under "general" only one file viewer can be defined.

Kindest,
Bubo.

Do you have another Windows XP installation to test it on?

I'm sorry, no other WinXP Pro installations.

I have three other suggestions:

1. I noticed two keys in HKCU\Software\SmartFTP\Client 2.0\Settings\General\ that may affect the file-viewing behaviour:
a. a REG_EXPAND_SZ key "File Viewer" that has the string value "%ProgramFiles%\NoteTab Pro\NotePro.exe" (but this program never gets started when viewing);
b. a REG_DWORD key "UseInternalFileViewer" that has the integer value "1" (I did not know there was such a thing as an internal fileviewer, but even this one does not get invoked when viewing).
Am I missing another registry setting that could cause this strange behaviour?

2. If you wish, I can provide you with a capture from Microsoft's Process Monitor. That should give an insight in what happens when I try to view a file.

3. Funny thing is that the command "open" does function properly: each file is simply opened in its appropriate program. Same is true for the command "edit": here too, each file is opened in its program as indicated by its association in Windiws and can be edited (plus is uploaded when saved).
F.i. a HMTL file "opens" in Firefox and when right-clicked on "edit" opens in Notetab Pro.
It's only the "viewing" that does not work.

Kindest,
Bubo.

Wonders never cease to exist: I run CCleaner, the registry cleaner part of it, and after that mysteriously the right-click "view" command now indeed launches the viewer as indicated!

Mat: I have no clue what key was the culprit, but I could upload the now deleted keys for you somewhere, should you be interested.

Anyway - problem fixed.
Kindest,
Bubo.

Hello Bubo ..

Ah good news indeed. If you can please upload the deleted keys. Or you can also send them by email, but in this case rename the .reg file to .txt to bypass the mail filter.

Updating status to: Working as Intended
Issue fixed in: None

Note to other users: My guess is that CCleaner removed/fixed a corrupt system registry key.

Hi Mat

Just checked all deleted keys and really could not find anything nearly related to this ... and then I suddenly realised I also made one change in the settings. In "general - navigation - double click action" I had changed the double-click action to "open" instead of "view" and guess whát: that was the reason why right-click on view worked!
Because when I change this setting back to double-click = view, again a folder gets opened.

With the double-click action set to "view" there is also a different icon: a sheet of paper with a little green arrow right under; with the double-click action set to "open" the right-click view command shows correctly the icon of the viewing program (NoteTab Pro in my case).

I guess this was not intended but still is a bug?
Kindest regards & good weekend,
Bubo.

Updating status to: Confirmed

Yep it's a bug and I was able to reproduce it with your instructions ;-)
Thanks.

Issue fixed in: 4.0.1091.0






0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users