Jump to content


Issue Information

  • #000030

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Transfer Queue doesn't detect changes in files

Posted by Bob Gregor on 10 November 2009 - 06:13 PM

I have been using the remote edit capability of SmartFTP extensively for over 2 years. I just updated to 4.0.1063.0 and found that it broke the automatic detection of local changes (and subsequent pushing of the file to remote).

I have to right click the local file, and click "process" for Smart FTP to push the changes.

Install the latest version and try again
http://www.smartftp.com/download

Fixed it! Thank you for your continuing excellent support & reliability!

I tweeted your praises :) @bobbravo2

Edited by Bob Gregor, 10 November 2009 - 08:38 PM.


Updating status to: Fixed
Issue fixed in: 4.0.1066.0

Thank you :-)

I've just upgraded to 4.0.1066.0 and this issue is still present on Windows7

Unable to reproduce. Please provide detailed instructions on how we can reproduce it. Thanks.

I have installed the latest build (and purchased a 3 year maintenance license) and am still having problems.

Steps to reproduce:
  • Open a remote FTP site
  • Right click a remote file -> Edit
  • Edit file in your txt editor of choice (I'm using Notepad++)
  • Save changes multiple times, try running the application for a while, and open multiple files
The issue seems sporadic, and I have methodically tried to reproduce the exact sequence above. The unclear point is when it stops detecting the changes.

My system:
Vista Ultimate 64-bit 6.0.6002
Smart FTP Professional 64bit 4.0.1066.0

Edited by Bob Gregor, 16 November 2009 - 07:51 PM.


Thanks. It seems shell notifications are no longer sent by the shell or no longer received by SmartFTP. To get a better idea we need to have a few more details. For example:
- Does it happen if you only open 1 file?
- Or do you have to open multiple files for it to happen?
- How many files do you need to open until you see it happen?
- How many file modifications (1-10, 10-100) are required?
- Does it happen with notepad as well?

Regards,
Mat

Reproducing the problem is proving problematic. To remedy it, I have to restart SmartFTP (fortunately not my OS ;) .

It seems to occur when I have many files open, and SmartFTP has been running a while, connected to multiple hosts. I am working on remote sites today, so I will post more details as I ferret them out

If you are interested I can provide you a debug version with the hope that it will show some kind of error when the problem occurs.

I haven't had the problem in about 24 hours. I'll let you know if it happens again, and then, yes i'd be happy to test the debug version for you :)

I reproduced this in a few steps just now. Doing the same steps again reproduced the problem again.

Shutdown and restarted smartFTP

Right click and Edit one file
Small change and save - everything fine

Right click and Edit second file (first still in queue)
Small change and save - everything fine

Close both files in editor
Remove both files from queue

Right click one of the same files and Edit
small change and save - no upload happens, no change in status

Clicked save several times, made some more changes, clicked save, nada.

Here's the logs. There is no final log for the expected last upload

Hope this helps.
Steve

[2009-11-18T18:05:45] Log opened
[2009-11-18T18:05:46] Resolving path "/home/web4ever/public_html/templates/vode2/css".
[2009-11-18T18:05:46] Path successfully resolved.
[2009-11-18T18:05:46] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/slatesblogs.css".
[2009-11-18T18:05:46] Attributes successfully obtained.
[2009-11-18T18:05:46] Downloading file "/home/web4ever/public_html/templates/vode2/css/slatesblogs.css".
[2009-11-18T18:05:46] Restarting at 0.
[2009-11-18T18:05:46] 7777 bytes transferred. (97.3 KB/s) (78 ms)
[2009-11-18T18:05:46] File successfully transferred.
[2009-11-18T18:05:46] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/slatesblogs.css".
[2009-11-18T18:05:46] Attributes successfully obtained.
[2009-11-18T18:05:46] Skipping integrity check.
[2009-11-18T18:05:46] Operation End
[2009-11-18T18:05:46] Log closed

[2009-11-18T18:05:56] Log opened
[2009-11-18T18:05:56] Initializing. Transfer Queue v4.0.1066.0.
[2009-11-18T18:05:56] Operation Begin
[2009-11-18T18:05:56] Resolving path "/home/web4ever/public_html/templates/vode2/css".
[2009-11-18T18:05:56] Path successfully resolved.
[2009-11-18T18:05:56] Uploading file to "/home/web4ever/public_html/templates/vode2/css/slatesblogs.css".
[2009-11-18T18:05:56] Restarting at 0.
[2009-11-18T18:05:56] 7778 bytes transferred. (97.3 KB/s) (78 ms)
[2009-11-18T18:05:56] File successfully transferred.
[2009-11-18T18:05:56] Setting attributes of "/home/web4ever/public_html/templates/vode2/css/slatesblogs.css".
[2009-11-18T18:05:56] Attributes successfully set.
[2009-11-18T18:05:56] Skipping integrity check.
[2009-11-18T18:05:56] Operation End
[2009-11-18T18:05:56] Log closed

[2009-11-18T18:06:01] Log opened
[2009-11-18T18:06:01] Initializing. Transfer Queue v4.0.1066.0.
[2009-11-18T18:06:01] Operation Begin
[2009-11-18T18:06:01] Resolving path "/home/web4ever/public_html/templates/vode2/css".
[2009-11-18T18:06:01] Path successfully resolved.
[2009-11-18T18:06:01] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:01] Attributes successfully obtained.
[2009-11-18T18:06:01] Downloading file "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:01] Restarting at 0.
[2009-11-18T18:06:01] 5696 bytes transferred. (71.3 KB/s) (78 ms)
[2009-11-18T18:06:01] File successfully transferred.
[2009-11-18T18:06:01] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:01] Attributes successfully obtained.
[2009-11-18T18:06:01] Skipping integrity check.
[2009-11-18T18:06:01] Operation End
[2009-11-18T18:06:01] Log closed

[2009-11-18T18:06:09] Log opened
[2009-11-18T18:06:09] Initializing. Transfer Queue v4.0.1066.0.
[2009-11-18T18:06:09] Operation Begin
[2009-11-18T18:06:09] Resolving path "/home/web4ever/public_html/templates/vode2/css".
[2009-11-18T18:06:09] Path successfully resolved.
[2009-11-18T18:06:09] Uploading file to "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:09] Restarting at 0.
[2009-11-18T18:06:09] 5697 bytes transferred. (71.3 KB/s) (78 ms)
[2009-11-18T18:06:09] File successfully transferred.
[2009-11-18T18:06:09] Setting attributes of "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:09] Attributes successfully set.
[2009-11-18T18:06:09] Skipping integrity check.
[2009-11-18T18:06:09] Operation End
[2009-11-18T18:06:09] Log closed

[2009-11-18T18:06:22] Log opened
[2009-11-18T18:06:22] Initializing. Transfer Queue v4.0.1066.0.
[2009-11-18T18:06:22] Operation Begin
[2009-11-18T18:06:22] Resolving path "/home/web4ever/public_html/templates/vode2/css".
[2009-11-18T18:06:22] Path successfully resolved.
[2009-11-18T18:06:22] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:22] Attributes successfully obtained.
[2009-11-18T18:06:22] Downloading file "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:22] Restarting at 0.
[2009-11-18T18:06:22] 5697 bytes transferred. (89.7 KB/s) (62 ms)
[2009-11-18T18:06:22] File successfully transferred.
[2009-11-18T18:06:22] Getting attributes of "/home/web4ever/public_html/templates/vode2/css/style.css".
[2009-11-18T18:06:22] Attributes successfully obtained.
[2009-11-18T18:06:22] Skipping integrity check.
[2009-11-18T18:06:22] Operation End
[2009-11-18T18:06:22] Log closed

Edited by Steve S., 19 November 2009 - 02:14 AM.


Did a little more simplification.

I just restarted SmartFTP, edit one file, remove the file from queue and closed the file. Edited same file and monitoring fails.

It doesn't matter whether I close the file first or remove from queue first.

Steve

Thanks. Bug confirmed. Bug fix will be in the next build.

Issue fixed in: 4.0.1071.0

The new version is available now.

Thanks for the quick response!

Thank you for catching how to reproduce that Steve, I have been narrowing it down, and you nailed it.





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users