Jump to content


Issue Information

  • #000023

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Excessive delay "preparing to copy"

Posted by gordy on 12 October 2009 - 06:46 AM

SmartFTP: v4.0.1054.0 64bit
OS: Windows 7 64bit

When dropping a file from explorer, this "preparing to copy" dialog appears for about 30 seconds before the upload occurs.

Posted Image

SmartFTP is searching for existing files. You can monitor the process in the log of the remote browser. If you want to skip this check click on the Automatic button in the dialog above.

nothing happens when I click the Automatic button

Post the log from the remote browser.

[22:14:19] CWD /gordy
[22:14:19] 250 Directory changed to "/gordy/"
[22:14:19] PWD
[22:14:19] 257 "/gordy/" is current directory.
[22:14:19] MLST 1255755061102.jpg
[22:14:19] xœ325Ðõõ	QÐOÏ/J©ÔwµÒw
	€rLMÍMMÌŒô²
[22:14:19] Òy¹250 command successful.
[22:15:19] Timeout (60s).
[22:15:19] Active Help: http://www.smartftp.com/support/kb/74
[22:15:19] Client closed the connection.
[22:15:19] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.

looks like the only reason the transfer appears to go through after the 60sec delay is because it goes into the queue

It almost looks like the server is sending garbage back. Can you post the beginning of the remote browser log as well?

Thanks
Mat

[19:57:52] SmartFTP v4.0.1054.0

[19:57:52] Resolving host name "xxxxxx"

[19:57:53] Connecting to xx.xx.xx.xx Port: 21

[19:57:53] Connected to xxxxxx.

[19:57:53] 220 Service ready for new user.

[19:57:53] USER xxxx

[19:57:53] 331 User name okay, need password.

[19:57:53] PASS (hidden)

[19:57:53] 230-Welcome xxxx from xx.xx.xx.xx. You are now logged in to the server.

[19:57:53] 230 User logged in, proceed.

[19:57:53] SYST

[19:57:53] 215 UNIX Type: L8

[19:57:53] Detected Server Type: UNIX

[19:57:53] RTT: 54.813 ms

[19:57:53] FEAT

[19:57:53] 211-Extensions Supported

[19:57:53]  COMB

[19:57:53]  MLST type*;size*;modify*;create*;perm*;

[19:57:53]  SIZE

[19:57:53]  XCRC

[19:57:53]  REST STREAM

[19:57:53]  EPRT

[19:57:53]  EPSV

[19:57:53]  MODE Z

[19:57:53]  DQTA

[19:57:53] 211 End

[19:57:53] Detected Server Software: Titan/VisNetic FTP Server

[19:57:53] PWD

[19:57:53] 257 "/" is current directory.

[19:57:53] CWD /gordy

[19:57:53] 250 Directory changed to "/gordy/"

[19:57:53] PWD

[19:57:53] 257 "/gordy/" is current directory.

[19:57:53] TYPE A

[19:57:53] 200 Type set to A.

[19:57:53] MODE Z

[19:57:53] 200 MODE Z Command OK..

[19:57:53] PASV

[19:57:53] 227 Entering Passive Mode (64,40,98,6,5,198).

[19:57:53] Opening data connection to 64.40.98.6 Port: 1478

[19:57:53] MLSD

[19:57:54] 150 File status okay; about to open data connection.

[19:57:54] 226 Closing data connection. Transferred 2483 bytes.

[19:57:54] 540 bytes transferred. (6.76 KB/s) (78 ms)

[19:58:02] CWD /gordy

[19:58:02] 250 Directory changed to "/gordy/"

[19:58:02] PWD

[19:58:02] 257 "/gordy/" is current directory.

[19:58:02] MLST 1255761040402.gif

[19:58:02] xœ325Ðõõ	QÐOÏ/J©ÔwµÒw

	€rLMÍÍL€ÐH/=3—

250 command successful.



Contact your web hosting provider or server administrator and ask them to upgrade to the latest version of Titan FTP server. I believe they have fixed the bug there.

Updating status to: Bug caused by 3rd party

Bug caused by 3rd party application.

anyway to disable smartftp from checking for conflicts for this site?

There is no way you can disable it.





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users