Jump to content

Issue Information

  • #000020

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)

Crash in Parallels

Posted by AgentTy on 23 September 2009 - 01:09 AM

I am a long time SmartFTP user, and I have had one consistent problem for the last 2 years.

I use SmartFTP on a Mac computer via Parallels. This crash only applies to instances of SmartFTP running via Parallels.

How to reproduce the crash:

1. Open SmartFTP
2. Open a new document in Apple's TextEdit app.
3. Type something, then select the text you typed.
2. Press Command+C (Apple Key + C) to copy the text.
3. Watch SmartFTP freeze hopelessly

That's it.... If you use the computers clipboard while SmartFTP is opened, it will crash... and it will also crash the Parallels Tools that synchronize the Windows and Mac clipboards. The only way to get clipboard working again is to reboot windows!

My uneducated guess is that there is some kind of module in SmartFTP that is monitoring the windows clipboard, and it gets in a cat fight with the Parallels clipboard module... and they both lose in the end.

I would really love to see this fixed... however I realize there aren't a lot of people out there using SmartFTP in parallels.

But.... speaking as a software developer myself... I'm willing to bet that my problem could be solved quite easily. By allowing me to disable (in user preferences or in some config file) whatever part of SmartFTP is interacting with the clipboard. No clipboard interface = no conflict = no crash = happy customer.

Any chance you guys could take care of this?



Please post the system information from the menu: Help->About "System Information" dialog.


I tried to contact you by email. Did you receive it?

Updating status to: Awaiting Feedback

Updating status to: Bug caused by 3rd party

It turned out that the bug is caused by Parallels:

The workaround is to disable the URL Watcher in SmartFTP until the bug in Parallels is fixed.
Menu: Tools->URL Watcher

After much fruitful correspondence with mb via skype, we have determined that this bug is caused by Parallels VM Software (specifically the "Shared Clipboard" portion of "Parallels Tools for Windows"). The freeze happens within this application or perhaps within the windows kernel and is therefore out of reach to the SmartFTP development team.

There is one thing you can do to avoid this problem when using SmartFTP, quite simply disable the "URL Watcher" feature, here are the instructions.
1. Open SmartFTP
2. Click "Tools" on the top menu between "View" and "Favorites"
3. If "URL Watcher" icon has an orange background color, it is currently ON, click it or press the W key to turn it OFF.

Once URL Watcher is off, you will no longer experience any SmartFTP crashes caused by Parallels Tools. You will also no longer be able to take advantage of the SmartFTP "URL Watcher" feature.
If you prefer to keep the "URL Watcher" feature enabled, your only other option is to disable "Share Clipboard" in the Parallels configuration.

I will be posting this issue with the Parallels Support Team. It does in fact affect ANY program which monitors the clipboard, causing other third party applications to freeze helplessly just like SmartFTP.

Thanks again to mb for being so helpful.


0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users