Jump to content


Issue Information

  • #000138

  • 0 - None Assigned

  • Confirmed

  • 4.0 (Build not known)

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

folder filter doesn't filter on merge during upload

Posted by kkez on 18 April 2011 - 05:39 PM

how to reproduce:

1) create a filter on the default favorite:
type: wildcard
value: world (could be any name, but it's this in my example)
scope: folder (name)

2) open any favorite favorite and on the local browser create a folder with name "hello", and inside that folder create another one with the name "world"

3) upload the folder "hello" to the remote browser with drag&drop -> results: the filter is correctly used and the folder "world" is not uploaded

4) reupload the same folder and select merge on the dialog

5) the folder "world" is uploaded regardless of the filter

Updating severity to: 0 - None Assigned
Updating status to: Not a Bug
Updating version to: 4.0 (Build not known)
Issue fixed in: None

This is by design.

well, sorry but for me it's bad design then.
why someone would want to filter on upload but not filter on upload+merge?
i have a .svn folder in each folder of my project, and I NEVER want it uploaded.

By the way, here's two different situations with different result.

First situation:
1) on the local browser, create a file on the parent folder of the folder "hello"
2) upload the file to the remote browser
3) now select the folder and the file and drag&drop the selection to the remote browser, but start the drag&drop from the file
4) click on "copy and replace" and "merge" in the warning dialogs
5) the filter is applied and no world folder is uploaded

Second situation:
1) make a copy the folder hello and name it "hello2", put it under the same folder as "hello" (it should still have the "world" subfolder)
2) on the local browser, create a file on the parent folder of the folder "hello"
3) upload the file and the folder "hello2" to the remote browser
3) now select the two folders and the file and drag&drop the selection to the remote browser, but start the drag&drop from the folder "hello2"
4) select "do this for all the conflicts" and then click on "merge", then click on "copy and replace" in the warning dialogs
5) the filter is applied to the folder "hello", but not to "hello2" (???)

Updating severity to: 0 - None Assigned
Updating status to: Confirmed
Updating version to: 4.0 (Build not known)
Issue fixed in: None

>1 situation
Yes this is a bug, the folder should not be filtered.

>2 situation
Same here, nothing should be filtered. E.g. hello.


Do you have a proposal when filters should apply and when not? The current design is that they are enabled for all transfers where the automatic rules apply but not for transfers for which they do not apply (e.g. when you manually merge folders) or any root item that is initiated by the user (e.g. user upload test.html but *.html is filtered).

I don't use automatic rules, I prefer having full control on what I'm doing and cancel the upload if done by mistake.
But are you saying that if I do use automatic rules and the rule says "merge", the filter is applied?

IMHO the filter should always apply, except (as you say) when a file/folder that should be filtered is directly and purposedly uploaded by the user.

If you want to maintain both behaviors, you could add a checkbox on the warning dialog that is checked by default and that says: "apply filters" . Or if you don't want to be checked by default, add an option for that.
Or you could add a list of files that are going to be filtered so the user can select whether or not to upload them.

Edited by kkez, 19 April 2011 - 11:18 AM.


any news on this issue/enhancement?

Updating severity to: 0 - None Assigned
Updating status to: Confirmed
Updating version to: 4.0 (Build not known)
Issue fixed in: None

Not yet. As soon as we have updates we will post them here.





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users