Jump to content

Issue Information

  • #000013

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)

Remote & local browser folder views entangled

Posted by ghostdingo on 30 August 2009 - 05:32 PM

Remote and local browser folder views become entangled.
E.G. if you local browse to folder/subfolder/ and then remote browse to equivalent folder/subfolder/ the local view is kicked back to folder/ and the remote view gets another subfolder (i.e. folder/subfolder/subfolder). This new version of subfolder is empty and doesn't exist if you try to delete it (but sometimes you can enter it and it's empty).
This usually happens immediately but sometimes you can be in the remote subfolder view for up to 30 seconds before the filenames suddenly disappear and this mysterious subfolder appears.

This started happening when I installed version 3.0.1043.0 (my previous version was six months old at least). At first it was only once an hour or so and I wasn't sure anything was happening. Then it became constant so I installed 3.0.1045.0 but the problem pnly became worse. I tried repairing but didn't help. Possible hint is that the installer now always says that Explorer is running (it isn't) but I have tried both ways of installing (let the installer try to close Explorer - it always fails but continues, and letting it continue without closing Explorer and then rebooting). At the moment the program is practically unusable.

Updating status to: Awaiting Feedback

Do you have the "Synchronize Browsing" feature enable?

Post the system information form the menu: Help->About "System information" dialog.

Then please describe detailed step by step instructions on how to reproduce.


If there is a 'Synchronize Browsing' feature please tell me how to find it as it's something I've been trying to do correctly. Currently I think the only changes from default settings are default favourites 'file exists' is set to 'use automatic rules' and 'integrity' is enabled in an attempt to achieve synchronization (it just copies everything though so I still end up doing it file by file). Turning 'file exists' back to 'ask' has no impact on this problem however.

System information is as follows:
+- System -----------------------------
Microsoft Windows Vista Home Premium Edition
Service Pack 1 (Build 6001)

CPU Speed : 2493 MHz
Total Memory : 2045 MB
Free Memory : 859 MB

+- SmartFTP ---------------------------
Version : 3.0.1045.0
Time Stamp : 2009-08-27 18:24:25
Platform : x86
Id : 400077821
Maintenance : 2009-09-16
Days in use : 450

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 8.0.6001.18813

+- Winsock ----------------------------
Winsock : 2.2

The problem happens all the time now but the simplest step by step breakdown is as follows:

1. Select main_folder in local browser
2. Select main_folder in remote browser
3. Select main_folder/sub_folder in remote browser
4. Select main_folder/sub_folder in local browser

At this point:
Local browser window goes blank
Remote browser window tries to open main_folder/sub_folder/sub_folder and fails (can't open folder)
Remote browser goes back to main_folder/sub_folder view (main_folder/sub_folder/sub_folder is now in view)
Local browser goes back to main_folder

The same thing happens if you swap steps 3 and 4. It's always the remote browser window where the ghost folder appears.

Also from this point on any subfolder you try to open in local browser is refused and its ghost folder appears in whatever subfolder is open in remote browser. In other words continuing on results in a complete mess and you can never open the same subfolder in both local and remote windows.

Further to above:

I installed version 4.0.1047.0 and the problem is now tighter in focus:

It's alway only happened in a particular folder that has about 80 subfolders. Now it's only happening in the last subfolder. I deleted it and recopied it but the problem persists.

If you have this last subfolder open in the remote browser and then open any of the other 80 or so subfolders in the local browser it tries to open it as a sub subfolder in the remote browser (and you get the ghost folder in there).

The "sync navigation" feature can be enabled by click on the the little button in the middle between the Local Browser and the Remote Browser.
There is also a tutorial at:

Please let us know if you have this feature enabled or not.


Sync Navigation is disabled (and enabling it has no impact on the problem either way).

Updating status to: Cannot Reproduce

I'm sorry but we cannot reproduce the problem :-(


Actually synchronized navigation does fix the problem (but it remains if it's disabled). I'd misunderstood it before, thinking it was for synchronising folders which I haven't had much luck with.

On that point, even though it's probably a new thread I also investigated visual compare which probably explains why I'm having issues synchronizing local and remote folders. I've inserted a link to a visual compare of one of my 80 sub folders (this is actually the problematic one we've been discussing but they're all the same in terms of files). I've looked at a few and they all give the same visual compare.

Posted Image

But does it make sense...? Can a file be equal in local and unequal in remote? Can files be unequal in remote and orphans in local? Is this how the automatic rules decide what to copy? As far as I'm concerned these folders should be equal.

Yep there is definitively a bug with the visual compare. I suspect it has something to do that the extensions are displayed in one browser and not in the other. We will look into that.

The transfer synchronization uses different rules to compare the files.


The bug with Visual Compare has been fixed in the latest version:

Thanks for the update. I installed this new version with interesting results:

1. The initial problematic folder with the ghost folders now works correctly with or without navigation synchronization.

2. If you click on nav sync with two different folders in the browsers the old problem comes back with local browser being kicked out of the folder and ghost folders appearing in the remote browser. Unsetting and then setting nav sync correctly with like folders fixes the problem (although ghost folders remain until ftp closed down).

3. Visual compare is slightly better - it now gets orphans correct. However it gets confused with some sub folders and marks everything else as unequal. Here's a jpg of a folder that was just synchronized (correctly) with automatic rules which clearly shows these issues:

Posted Image

4. This last automatic rule sync didn't put entries for the three transfered files in the on-screen log (the transfer I had just done previously had put the filenames of transfered files in the log). This unreliable nature of the log makes it hard to verfiy what's happening at times.

5. You mentioned this visual compare problem might be related to the local browser filename not displaying an extension. My question is how can I get it to display the extension as I've been trying for ages? I occasionally get given .JPG files instead of .jpg and your program just overwrites the .jpg as though they're the same but unfortunately most other programs see them as different. So seeing the extensions up front would be handy.

It's a known problem when the sync navigation featuer is enabled.

Indeed, there are more bugs in the visual compare feature (e.g. the cv folder should not be red). But the files are red because the date/time does not match. Your server lacks a feature to set the date/time of remote files hence the date/time is never equal. To ignore the date/time when comparing files go to the visual compare settings.

You have to look at the transfer log if you would like to debug the transfer process. However this is only necessary if you think there is a bug with the transfer synchronization feature.

Go to the Windows Explorer. Then go to the menu: Tools->Folder options. Go to the View tab and uncheck [x] Hide extensions from known file types


Okay - thanks for all your help.

I was wondering if you can email us the image you have previously posted in your last email? Can you send it to support at smartftp.com

Thank you

Sorry I don't have it any more. I did try to replicate it as the folders haven't changed but I had no luck. With 'compare date and time' disabled it worked fine and if I switch it back on the only previous error (the folder conflict) doesn't reappear.

The other thing of note in the original image was the absence of the icons before the local browser names of the three files transfered. They simply disappeared at the end of the transfer.

I also note that this last version of SmartFTP is the first one in well over two years that doesn't put up a red 'can't check file existance' (or something like that) before each file transfer. I don't know it that has any bearing on anything though.

Anyway if you need an image like the one I deleted I'm happy to do another transfer / visual compare if you like.

If you can reproduce the problem with the folder conflict and the missing icons that would certainly help us to find and fix the bug.

>can't check for file existance
This message is important and has a purpose. If you dont see it any longer then you might be using different settings than the defaults.


I tried to replicate the problems by repeating the steps but with not much success. And frankly I'm loathe to push things too much as it's been a long time since I've had the program working how I want it! Couple of things though:

With sync nav enabled sub folders are now all clear (equal I assume) regardless of whether or not they are equal internally.

The icons (occasionally) disappearing comes from changing the folder view from say medium to details with sync nav on. Doesn't happen every time though.

On that point sync nav only highlights files when the view is details. Possibly that's what meant to happen anyway.

As for 'can't check existance' it's been a constant from say version 2 (at least 2 or 3 years ago anyway) until this latest version. No defaults are changed other than using sync nav and visual compare (turning them off doesn't change things). That said integrity is on in default favorite - not sure if this is actually default state or not? I had turned on automatic rules in default favorite for awhile but now I'm doing it via the transfer prompt (and I couldn't remember if I'd touched integrity).

Sorry I meant to say:

The icons (occasionally) disappearing comes from changing the folder view from say medium to details with visual compare on. Doesn't happen every time though.

On that point visual compare only highlights files when the view is details. Possibly that's what meant to happen anyway.

ghostdingo: The redraw problem with Visual Compare has been fixed in the latest version 4.0.1050: http://www.smartftp.com/download

0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users