Jump to content


Issue Information

  • #000120

  • 0 - None Assigned

  • Cannot Reproduce

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Trying to delete an Item in transfer queue deletes Remote Browser selected folder or file

Posted by joplaal on 09 February 2011 - 11:41 AM

Steps to reproduce the bug:

Open a remote browser.
Select a folder, and click to download it. (adding to transfer queue)
Select a subfolder on the transfer queue
Try to remove this this subfolder by pressing delete key.
Instead of removing this item from the transfer queue, the selected folder on the remote browser will be deleted!!

On my previous v3 version worked well as I expected.

That bug made me to lose important information on remote server!!


Roger Garstang
Feb 09 2011 03:01 PM
Are you using 32bit or 64bit version? I have a lot of sub folders on my site, so was worried about this. I created some folders with subfolders 1, 2, 3, and 4 levels deep (with large files in them to stay in the queue a while) and downloaded them then deleted each sub folder from the queue using Del key and X button on toolbar multiple times and couldn't see this in 64bit version. I even changed my worker thread count to make it so a subfolder was added and waiting without a thread to start its file contents and deleted that sub folder.

I'm using 64bit version.

But it's not a question about subfolders. It happens with any item (file o folder).

The point is that when you focus one item at the transfer queue, and press delete (trying to remove it from the transfer queue), the action executed is to delete the selected item in remote browser.

Edited by joplaal, 09 February 2011 - 03:13 PM.



Roger Garstang
Feb 09 2011 03:18 PM
Weird. Yeah, in my tests I deleted the files as well and even tried files first then subfolders. May be a specific OS and/or focus problem. Listviews have a habit of behaving different in various versions of OS and whether themes are enabled or not. There are at least 3 Microsoft bugs in XP and XP 64bit related to Listviews that were never fixed. With Vista+ they went away because Listviews were rewrote, but that also introduced new problems.

I'm using Windows 7

Updating status to: Cannot Reproduce

Try this:
http://www.smartftp....ings-f2625.html





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users