Jump to content

Issue Information

  • #000114

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)

Text Editor - Syntax Highlighting does not work on XP

Posted by R0ss on 18 January 2011 - 11:23 AM

Since I upgraded to v4.0 Build 1148 in December, Syntax highlighting in text editor is no longer working.
I've tried a couple of next builds, currently with 4.0.1154.0, tried to completely uninstall/reinstall, and to delete the registry - nothing worked.
Changing anything in Settings > Text Editor > Font does not make a difference to the editor's display at all too - it keeps using MS Sans Serif, black for everything (html, php, css, js, txt...)

I also notice that Settings > Text Editor > Styles is empty for me, no file types, no attributes. Is it supposed to be that way?
Am I missing something?

I am on XP SP3.


Updating status to: Awaiting Feedback

Please install the latest version:

I did that, with no effect.
I can provide a screenshot how it looks like right after the reinstallation of 4.0.1161.0 and a clean registry.

Then I went further, uninstalled the application, deleted all left files and removed all registry keys (classes, etc.) where the word "smartftp" appeared.
Then installed version 4.0.1138 (I've kept the installer from before), that one was sure to have syntax highlighting working for me - and again nothing, no fonts, no colors, plain text area.
Finally I uninstalled 1138 and reinstalled 1161.

I understand that this might be a windows problem, not yours, like a broken or missing edit component, but anyway if you have any ideas how to resolve it, it would be greatly appreciated. The built-in text editor was a great addition to SmartFTP, but without syntax highligting, and even without Courier as a font, I can't use it.

(FYI, I am a registered user, license # 400062949, to the name of Oystein J Wright, but using a forum account that was created while the product was free and could not find where to enter the license # in my account.)

Thanks again!

Try to delete the following file:
%appdata%\SmartFTP\Client 2.0\TextEditorStyles.xml

That did it!

The file contained the following:

<?xml version="1.0"?>
<Settings><Global/><Styles/><Languages><Language ID="51" Name="Global" ReplaceTabBySpace="0" TabSize="2"/></Languages></Settings>

after deleting and restarting, now I can see all kinds of styles in Settings > Text Editor > Styles, which was blank before.
I should have thought it was something from the %appdata%\SmartFTP\Client 2.0\ folder because it was the only trace of SmartFTP that I had not removed while reinstalling, because I wanted to preserve my Favorites, history, backup and the license file.

Thank you so much!

Updating status to: Resolved

You are welcome. The problem has most likely been caused by a buggy build of SmartFTP.

0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users