Jump to content


Issue Information

  • #000105

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Remote browser file list does not redraw

Posted by R0ss on 28 September 2010 - 09:00 PM

After upgrading to 4.0.1138.0 I find that the remote browser file list does not redraw itself when refreshing (hitting F5 or the Refresh toolbar button).
I can see in the Log pane that the Refresh command actually gets carried out, but the file list does not redraw itself to show the updates. If I navigate to another folder (in the remote browser), then get back to the previous one, the newly updated files (result of the refresh command) show up without network refreshing.

The same happens no matter if a new file has been dropped on the server by another process, outside of smartftp, or if a new file has been uploaded by the same SmartFTP client but through the Transfer Queue - on queue complete, MLSD command is passed to the server and response received, but the list view just does not redraw.

Never had that problem with previous versions on the same machine. Deleting all registry keys for settings did not work either.
OS: Win XP Pro

Thanks.

Thank you for your report. Do you remember the last version where it worked?

On my computer I last had 4.0.1090 before upgrading to .1138
But I just checked a fellow's PC running 4.0.1133 and it does not have that problem.
The other computer has Windows XP Home, both are SP3 with automatic updates.

Btw I just found that the redraw problem shows up even when deleting a remote file - I have to navigate away and back again to see that the file is gone.

Updating status to: Awaiting Feedback

The shell notifications might be blocked by a buggy software firewall or antivirus product. Try to uninstall them temporary and try again.

The only firewall/antivirus product running on this computer is Norton 360. I disabled it temporarily and the problem persists.
If you could provide me with a download link for smartfrp version 4.0.1133 (and confirm that the installer will work fine when downgrading from .1138), I could try that and let you know if .1133 works ok in the very same environment. But the other computer that I reported, running .1133, also has the same version of Norton 360, and does not have issues.

The way I see it, it is a problem of the interface, Redraw event not being passed to the filelist, it does not even blink upon refresh; while all the network operations work fine. But this is just a wild guess, of course you know your software better.

From what I understand none of the shell notifications go through. That is why my guess is that another application is blocking them. We had customers with the same problem in the past and uninstalling the software firewall / antivirus product fixed it. Please temporary uninstall Norton 360.

Uninstalled Norton, restarted PC, nothing changed.
Some more info - when I delete or upload a whole folder, the Folders list gets updated, only the Files list does not until I change to another folder.

Please provide me with a download link for a previous version.

Please try build 1124:
http://www.filehippo...artftp/history/

Delete the registry after you have uninstall the newest version of SmartFTP.

Sorry for delayed reply. This issue's been resolved with the next upgrades; must have been a problem with the registry settings and/or Windows.
You can change status to 'bogus'
Thanks!

Updating status to: Resolved





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users