Jump to content


Issue Information

  • #000104

  • 0 - None Assigned

  • Unfiled

  • -

  • -

Issue Confirmations

  • Yes (0)No (0)
Photo

Date modified issue.

Posted by Xiaodong Chen on 27 September 2010 - 08:23 AM

+- System -----------------------------
Microsoft Windows 7 Ultimate Edition
(Build 7600)

CPU Speed : 1828 MHz
Total Memory : 2046 MB
Free Memory : 350 MB

+- SmartFTP ---------------------------
Version : 4.0.1138.0
Time Stamp : 2010-09-18 00:27:58
Platform : x86
Id : 400126619
Maintenance : 2011-06-02
Days in use : 45

+- Language ---------------------------
en-US

+- Internet Explorer ------------------
Version : 8.0.7600.16385

+- Winsock ----------------------------
Winsock : 2.2



When i transfer all fill to server, the date modified the same as my workstation, but after i refresh the remote view, the date modified changed, lost time info, all time set to "12:00AM". when right click the file to check the Property, the date modified update to the right date time, please help.


Updating status to: Awaiting Feedback

Please post the log of the transfer. Most likely your server does not offer a command/feature to set the date of a remote file.


Xiaodong Chen
Sep 28 2010 12:51 AM
FYI, attached the screenshot, please help check the reason. thanks


Posted Image

Please post the log of the transfer: Double click the file in the transfer queue window (enable the queue window first: View->Panes->Queue).

I believe your server returns the local file time in the directory listing (LIST). When you you go to the properties dialog of a file, SmartFTP requests additional information such as the date/time in UTC from the server. Since this time is correct or more exact than the one returned in the listing (LIST) the view is updated accordingly. The problem can be fixed if your server supports the MLSD command. My recommendation is to contact your server administrator and encourage him/her to install a modern FTP server.





0 user(s) are reading this issue

0 members, 0 guests, 0 anonymous users