Jump to content


Photo

Firefox bug: Cannot copy and paste URL


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 kennethy

kennethy
  • Members
  • 4 posts

Posted 07 August 2005 - 10:22 AM

When SmartFTP isn't running, I cannot cut-and-paste urls from the Address bar in Firefox into something like Notepad. If I had some text in the clipboard before, it gets wiped out when you Copy the url. But I'm unable to paste after that.

When SmartFTP is running, cut-and-paste works as normal.

This bug happens regardless of whether URL Watcher is turned on or off. It doesn't occur in MSIE 6.0. Normal text (eg text in the webpage) can be cut and pasted as normal.

Bug also occurs in html forms on a webpage (as I'm finding out right now). I can't copy-and-paste text in this form unless I have SmartFTP running in the background.

Reproduction Steps:
1. With SmartFTP not running, open a website in Firefox.
2. Press Alt-D to go to the Address Bar.
3. Copy the url.
4. Open a text document.
5. Paste the URL into it. Observe the lack of reaction (if using a shortcut key) or the disabled Paste command (if using the mouse right-click menu).

SmartFTP version: 1.5.988
Browser: Mozilla Firefox 1.0.6
Operating System: Windows XP

#2 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 07 August 2005 - 10:41 AM

I cannot reproduce the problem.

What version of SmartFTP are you using? menu: Help->About "System Information".

-Mat

#3 kennethy

kennethy
  • Members
  • 4 posts

Posted 07 August 2005 - 12:05 PM

Damn I uninstalled SmartFTP and it didn't fix the problem. Either SmartFTP has left behind some registry keys, modified some Firefox setting, or it's a mysterious Windows problem. But it doesn't explain why running SmartFTP fixes the problem.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2813 MHz
Total Memory : 1048044 KB
Free Memory : 439280 KB

+- SmartFTP ---------------------------
Version : 1.5.988.47
Time Stamp : 2005-07-23 03:06:42

+- Application DLL --------------------
Controls.dll : 1.6.988.47
sfFTPLib.dll : 1.5.3.0
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 1.5.988.47

+- System DLL -------------------------
unicows.dll : 1.0.4018.0
shell32.dll : 6.00.2900.2620 (xpsp_sp2_gdr.050225-1820)
shlwapi.dll : 6.00.2900.2627 (xpsp_sp2_gdr.050309-1648)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

#4 kennethy

kennethy
  • Members
  • 4 posts

Posted 07 August 2005 - 12:26 PM

Ok I don't have any reliable reproduction steps. I open up a new Firefox instance, and I use shortcut keys to copy and paste. Sometimes it's the 2nd time I use Ctrl-C/Ctrl-V, and sometimes it's the 3rd time. Like it was working normally about 10 secs ago, and after a few copy/pastes, it now doesn't work. I haven't changed anything... it's just copying the URL. If I do it repeatedly, it sometimes changes behaviour.

Might not have anything to do with SmartFTP. Could be a Firefox thing.

#5 kennethy

kennethy
  • Members
  • 4 posts

Posted 07 August 2005 - 01:20 PM

Can no longer reproduce. I reproduced it about 8 times, and now it seems to work all the time.