Jump to content


Photo

Upload problem: File size mismatch


  • Please log in to reply
13 replies to this topic

#1 Mathachew

Mathachew
  • Members
  • 16 posts

Posted 24 June 2005 - 05:59 PM

Here's the log:

SmartFTP v1.5.988.24
Resolving host name ____________
Connecting to ____________ Port: 21
Connected to ____________.
220 Microsoft FTP Service
USER ____________
331 Password required for ____________.
PASS (hidden)
230 User ____________ logged in.
SYST
215 Windows_NT
FEAT
211-FEAT
SIZE
MDTM
211 END
TYPE I
200 Type set to I.
REST 0
350 Restarting at 0.
PWD
257 "/" is current directory.
CWD /httpdocs
250 CWD command successful.
PWD
257 "/httpdocs" is current directory.
PORT 192,168,1,100,10,60
200 PORT command successful.
LIST
150 Opening BINARY mode data connection for /bin/ls.
226 Transfer complete.
19855 bytes transferred. (82.8 KB/s) (234 ms)
CWD /httpdocs/ameast
250 CWD command successful.
PWD
257 "/httpdocs/ameast" is current directory.
PORT 192,168,1,100,10,62
200 PORT command successful.
LIST
150 Opening BINARY mode data connection for /bin/ls.
817 bytes transferred. (49.8 KB/s) (16 ms)
226 Transfer complete.
CWD /httpdocs/ameast/MBskB_A
250 CWD command successful.
PWD
257 "/httpdocs/ameast/MBskB_A" is current directory.
PORT 192,168,1,100,10,64
200 PORT command successful.
LIST
150 Opening BINARY mode data connection for /bin/ls.
226 Transfer complete.
16967 bytes transferred. (66.2 KB/s) (250 ms)
SIZE availcalendar2.asp
213 7650
MDTM availcalendar2.asp
213 20050326062137
PORT 192,168,1,100,10,66
200 PORT command successful.
STOR availcalendar2.asp
150 Opening BINARY mode data connection for availcalendar2.asp.
9598 bytes transferred. (37.4 KB/s) (250 ms)
226 Transfer complete.
SIZE availcalendar2.asp
213 7650
File size mismatch.
PORT 192,168,1,100,10,68
200 PORT command successful.
LIST
150 Opening BINARY mode data connection for /bin/ls.
226 Transfer complete.
16967 bytes transferred. (76.0 KB/s) (218 ms)
Transfer failed.


Before upgrading to 1.5.988, uploading files was not a problem. This problem that I am experiencing prompted me to stop using the Dev Builds because I could not get around the transfer error. The funny thing about this problem is that it does not always occur. I've just edited 4 file that need to be uploaded and are larger than the files on the server. I get the File Size mismatch error right away and the files will not transfer.

The weird part is that sometimes the files will transfer, other times they won't.

Any suggestions? I've seen other have a problem with the program waiting about 15 to 20 seconds to upload, but this isn't the case for me, it's a case of not uploading at all because the file sizes are different.

Also: the Remote browser listing of files still isn't working right. I posted a new topic about this about a month ago and Matt said it was fixed. My Local browser lists by File Type in Ascending order, with the files listed alphabetically in ascending order. The remove view lists the files in descending order, from Z to A, where the Local browser lists from A to Z. Just an FYI.

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2405 MHz
Total Memory : 1047280 KB
Free Memory : 550292 KB

+- SmartFTP ---------------------------
Version : 1.5.988.24
Time Stamp : 2005-06-24 00:57:16

+- Application DLL --------------------
controls.dll : 1.6.988.24
sfFTPLib.dll : 1.0.1.38
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 1.5.988.24

+- System DLL -------------------------
unicows.dll : 1.0.4018.0
shell32.dll : 6.00.2900.2620 (xpsp_sp2_gdr.050225-1820)
shlwapi.dll : 6.00.2900.2668 (xpsp_sp2_gdr.050430-1553)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

#2 mb

mb

    Developer

  • Administrators
  • 11848 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 24 June 2005 - 08:06 PM

1st problem: Use Passive Mode (PASV) instead of Active Mode (PORT). Settings->Connection "Data Transfer Mode"

2nd problem: We have to check it again.

Regards,
-Mat

#3 Mathachew

Mathachew
  • Members
  • 16 posts

Posted 26 June 2005 - 07:52 PM

The reason it was Active is because I was trying what I saw others suggest in the other forums. I have set it back to Passive and it did not work.

During my trial and error testing, having set the Encoding from Auto to ASCII (via the icons) allowed me to upload my updated ASP pages. When dealing with the Access DB files, the uploads worked fine no matter what the setting was.

I always had it on Auto and the connection as Passive (which I assume is always the default when installing) and it worked before the lastest build. I hope this sheds some light.

And if you need any other details on the 2nd problem with the file listing, let me know; I can provide some screenies to show what I mean.

Great work guys! I love it!

#4 Eckat

Eckat
  • Members
  • 3 posts
  • Location:
    Germany

Posted 28 June 2005 - 02:12 PM

I have the same problem.
When I try to upload a file to some ftp-servers, I get an error-Message, but the transfer works. Second Problem: After one error-Message, the Transfer stops, so only one file is uploaded.

log:
   SmartFTP v1.5.988.28

    Resolving host name "people-ftp.freenet.de"

    Connecting to 194.97.107.90 Port: 21

    Connected to people-ftp.freenet.de.

220 freenet FTP-Homepage Server ready

    USER ******

331 Password required for ******.

    PASS (hidden)

230 User ****** logged in.

    SYST

215 UNIX Type: L8

    FEAT

211-Features:

 MDTM

 REST STREAM

 SIZE

211 End

    PWD

257 "/" is current directory.

    TYPE I

200 Type set to I

    PORT 192,168,2,31,4,142

200 PORT command successful

    LIST -aL

150 Opening ASCII mode data connection for file list

    191 bytes transferred. (N/A/s) (0 ms)

226-Transfer complete.

226 Quotas on: using 61428.36 of 61440.00 kb, files 42 of 500, dirs 1 of 100, max file size 1536.00 kb

    SIZE test.txt

550 test.txt: No such file or directory

    PORT 192,168,2,31,4,143

200 PORT command successful

    STOR test.txt

150 Opening BINARY mode data connection for test.txt

    6 bytes transferred. (76 Byte/s) (78 ms)

226 Transfer complete.

    SIZE test.txt

550 test.txt: Permission denied

    File size mismatch.

    PORT 192,168,2,31,4,144

200 PORT command successful

    LIST -aL

150 Opening ASCII mode data connection for file list

    256 bytes transferred. (N/A/s) (0 ms)

226-Transfer complete.

226 Quotas on: using 61428.37 of 61440.00 kb, files 43 of 500, dirs 1 of 100, max file size 1536.00 kb

    Transfer failed.


The Providers only supports active-connections, so passive is no alternative.

The size of the file ist completly insignificant.
The MS-Hotfix KB893066 is uninstalled.

Is use the following System:

AMD Athlon XP 2800+
ASUS A7V600
512 MB DDR-RAM

Windows XP Pro with SP2
Hotfixes/Updates:
- KB884020
- KB890046
- KB890859
- KB896626
- KB893086
- KB893357
- KB894391
- KB896358
- KB896422
- KB896428
- KB883939
- KB888302
- KB885836
- KB885835
- KB885250
- KB888113
- KB886185
- KB891781
- KB873339
- KB887742

SmartFTP 1.5.988

I use an AVM Fritz!Box WLAN 7050 as my Router. It has the IP 192.168.2.1 and my PC 192.168.2.31

#5 mb

mb

    Developer

  • Administrators
  • 11848 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 June 2005 - 03:05 PM

Use the Global Queue for all your transfers.

If you want to stick with the Direct Uploads (not recommended) go to the Settings->Transfer->Files and check the "Ignore Error" option.

-Mat

#6 Eckat

Eckat
  • Members
  • 3 posts
  • Location:
    Germany

Posted 28 June 2005 - 04:47 PM

I activated "Settings" -> "Queue" -> "Options" -> "Start Queue on Startup". This dosn't make anything better.

Was this Setting wrong? Where should I activate th global Queue?

many thx!

#7 mb

mb

    Developer

  • Administrators
  • 11848 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 28 June 2005 - 07:14 PM

Please see the tutorials at:
http://www.smartftp.com/support/howto

#8 Eckat

Eckat
  • Members
  • 3 posts
  • Location:
    Germany

Posted 28 June 2005 - 08:51 PM

Ok, for Downloads I understand it. But Uploads doesn't work. I can't add them to the global Queue.

For a Moment I use the second solution. But ignoring the errors isn't very good, i think.
The problem seems to be the SIZE command before and after uploading each file.

thx for your help :lol:

#9 robtbs

robtbs
  • Members
  • 2 posts

Posted 29 June 2005 - 01:16 PM

iv been getting the same issue...
iv finally worked out the global queue...

why not just make the global queue the default option?
multithreading is well better.

personally i see no need for the direct transfer option. as all you want to do is transfer files as quick as possible.
and the queue shows you how long is left/what is left.

Maybe something for the next version....?


also iv found that same prob happening with the queue..
File size mismatch.

I couldnt understand why the last item in my queue kept going round n round n round...
connecting... pre-transfer... uploading... etc etc

i think you really need to stop that filesize check after uploads.
its windows servers... they they dont update until you exit the current thread... so asking for filesize during the upload thread gives the size of the old file.

#10 robtbs

robtbs
  • Members
  • 2 posts

Posted 29 June 2005 - 01:30 PM

iv ticked the
"ignore zero filesize"
in the transfer options...
this seems to have resolved the looping transfer of files.

#11 Peasant

Peasant
  • Members
  • 6 posts

Posted 30 June 2005 - 01:13 PM

I've been getting the same problem. SmartFTP worked fine until today when I upgraded to the latest version. Now it refuses to upload files because of a file size mismatch problem.

I used to always just drag the files I wanted to upload from the local browser window into the remote window and that worked perfectly - I never used the global queue because I can't make head or tail of how to. (Sorry, but your how-to texts leave a lot to be desired.)

As instructed in this thread I tried using the global queue for the first time. It is far less convenient than quickly dragging and dropping but needs must. I did manage to upload the file the first time. I had no indication from Smart FTP that the file upload had been successful but viewing the website showed it had been.
But the file still had a problem so I quickly reedited and tried to upload again -
I dragged it onto the queue source.
I clicked the tab for global queue
The blue upload button is greyed out.
:?
I can get the blue upload button back only by closing SmartFTP and reopening it - which is obviously a right pain.


I have no idea if this is me not understanding the global queue or if it is all part of the same bug.

Meanwhile, where do I get an older build of SmartFTP so I can go back to the much quicker and more convenient direct transfers?

#12 jeanlyon

jeanlyon
  • Members
  • 4 posts

Posted 30 June 2005 - 07:28 PM

Please tell me where I can get the old version back. The new one will not work with one of my servers.

#13 Peasant

Peasant
  • Members
  • 6 posts

Posted 30 June 2005 - 08:37 PM

Just discovered a further problem with this new build–the file mismatch problem also arises when you try to edit a file directly.

I did manage to solve my global queue problem–the tutorials don’t mention it but there is an option in the settings to ‘stop’ the queue after the transfer has finished. It is then available to use again. I mention this here to help some other poor confused soul.

#14 mb

mb

    Developer

  • Administrators
  • 11848 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 30 June 2005 - 10:06 PM

Please make a proper bug report including the log of your FTP session, the system information (Help->About) and instructions how to reproduce it.

This is the ONLY way we can quickly fix bugs. Bugs are usually fixed within the next 48h after we received a complete bug report.

Thank you.
Regards,
SmartFTP




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users