Jump to content


Photo

SmartFTP Installation Problems


  • This topic is locked This topic is locked
25 replies to this topic

#21 jberger

jberger
  • Members
  • 2 posts

Posted 07 September 2007 - 09:34 PM

I was using Smart FTP (I don't know what version) and it said my build was about to expire, so I downloaded a newer build, using the link on the message. After downloading yesterday, I was able to use the software without a problem. Today, when I went to go use it, it says that "The source installation package for the product SmartFTP client is out of sync with the client package. Try the installation again using a valid copy of the installation package 'SmartFTP.msi'." I have tried re-downloading the software, but it doesn't help.

HELP!!

#22 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 07 September 2007 - 09:40 PM

Uninstall the version installed and install it again.

Regards,
Mat

#23 michaeljames

michaeljames
  • Members
  • 1 posts

Posted 21 September 2007 - 10:23 PM

[quote name='mb' date='Nov 11 2004, 09:39 PM' post='25747']
According to the recent poll we ran on the web site, there is a certain amount of users having problems with the official setup.
The official setup is the one available here:
http://www.smartftp....get/SFTPMSI.exe

We are interested to know what kind of problems you have/had installing SmartFTP.

Thank you SO much for the official setup link above. When I tried to install the program, the link I downloaded didn't work, and I got a message onscreen about windows/system32/advpack.dll which didn't make a lot of sense to me. Anyway, your link above worked a treat, and the program installed/setup instantly, and it seems to be performing just fine! <_<
Thanks again and, in return, I promise to buy the program as soon as my site generates some income! :angry:

Keep smiling!

Mike

Edited by michaeljames, 21 September 2007 - 10:24 PM.


#24 Pactum

Pactum
  • Members
  • 1 posts

Posted 10 October 2007 - 12:59 AM

I licensed SmartFTP a few years ago. I downloaded and installed 2.5 yesterday. I didn't notice any warnings that I was going to lose my licensed version until I went to start up 2.5. Then I was informed that my license has expired and I'm not qualified to use 2.5. Trouble is, since the new install I can't find my earlier version - it seems to have been overwritten. Is this some sort of forced upgrade? I was satisfied with my earlier version; I really don't want to shell out money for something I don't need, although I'll likely upgrade at some point.

What am I supposed to do?

Thanks!

P.S. I'll also add that all my previous settings have been lost too.

Edited by Pactum, 10 October 2007 - 01:29 AM.


#25 Russell

Russell
  • Members
  • 2 posts

Posted 01 November 2007 - 08:28 PM

I had the free version of smartFTP install and it work fine.

Then I tried to install the new release and received the following error message:

["The installed product does not match the installation sources. Until a matching source is provided
or the installed product and source are syschronized, this action cannot be performed.]

When I try to install in the same location as the previouse product, I get the
following message:

"C:\Documents and Settings\Russell\Desktop\SmartFTP Client Setup Files\SmartFTP.msi
is not a valid installation package foe the product "SmartFTP Client"
Try to find the installation package "SmartFTP.msi" in a folder from which you can install
SmartFTP Client]

Even when I try to use the older version I now get that message.

Any help is appreciated.

Thanks.

Russell



According to the recent poll we ran on the web site, there is a certain amount of users having problems with the official setup.
The official setup is the one available here:
http://www.smartftp....get/SFTPMSI.exe

We are interested to know what kind of problems you have/had installing SmartFTP.

Problem
Setup was unable to upgrade the windows installer. Failed to load 'msi.dll'

Fix
Please install this one:
http://www.microsoft...;displaylang=en

Problem
When I try to start it, is says "could not access network location:."

I have tried uninstalling, but I can't do that either, because I get the same error. I tried downloading the NSI version, but as soon as it tries to install, I get the same message. I have no choices with the message but "retry" or "cancel". Retry does nothing, of course. If I cancel, I cancel the install or removal. What do I do??

The file 'path to SmartFTP Client Setup Files" is not a valid installation package for the product SmartFTP Client. Try to find the installation package in a folder from which you can install SmartFTP Client.

Fix
Download the Windows Installer CleanUp Tool from:
http://support.micro...kb;en-us;290301
and use the tool to remove SmartFTP from the installed applications.
Then run the SmartFTP NSI setup from:
http://www.smartftp....get/SFTPNSI.exe

Problem
When I try to start SmartFTP for the first time after installing, I get an error message "The SMARTFTP.EXE file is linked to missing export SHLWAPI.DLL:PathUnExpandEnvStringsW." Restarting, uninstall/reinstalling and using the repair function through Add/Remove programs have not had any effect.

Fix
Install Internet Explorer 5.x or higher and make sure the unicows.dll is in the SmartFTP application directory.

Please post a short description what isn't or wasn't working for you.

Thank you for your time.
-Mat
SmartFTP.com



#26 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 01 November 2007 - 09:11 PM

It's more than enough to make one posting for the same problem.

Thank you.
Regards,
SmartFTP




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users