Jump to content


Photo

SmartFTP Installation Problems


  • This topic is locked This topic is locked
25 replies to this topic

#1 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 11 November 2004 - 08:39 PM

According to the recent poll we ran on the web site, there is a certain amount of users having problems with the official setup.
The official setup is the one available here:
http://www.smartftp....get/SFTPMSI.exe

We are interested to know what kind of problems you have/had installing SmartFTP.

Problem
Setup was unable to upgrade the windows installer. Failed to load 'msi.dll'

Fix
Please install this one:
http://www.microsoft...;displaylang=en

Problem
When I try to start it, is says "could not access network location:."

I have tried uninstalling, but I can't do that either, because I get the same error. I tried downloading the NSI version, but as soon as it tries to install, I get the same message. I have no choices with the message but "retry" or "cancel". Retry does nothing, of course. If I cancel, I cancel the install or removal. What do I do??

The file 'path to SmartFTP Client Setup Files" is not a valid installation package for the product SmartFTP Client. Try to find the installation package in a folder from which you can install SmartFTP Client.

Fix
Download the Windows Installer CleanUp Tool from:
http://support.micro...kb;en-us;290301
and use the tool to remove SmartFTP from the installed applications.
Then run the SmartFTP NSI setup from:
http://www.smartftp....get/SFTPNSI.exe

Problem
When I try to start SmartFTP for the first time after installing, I get an error message "The SMARTFTP.EXE file is linked to missing export SHLWAPI.DLL:PathUnExpandEnvStringsW." Restarting, uninstall/reinstalling and using the repair function through Add/Remove programs have not had any effect.

Fix
Install Internet Explorer 5.x or higher and make sure the unicows.dll is in the SmartFTP application directory.

Please post a short description what isn't or wasn't working for you.

Thank you for your time.
-Mat
SmartFTP.com

#2 pkla

pkla
  • Members
  • 3 posts

Posted 04 April 2006 - 01:23 PM

Have been using the 1.9 SmartFTP (unlicensed) on my pc with the Me operating system with no problems. Last week the 2.0 was pushed and required. The opening screen shows transfer forms. In trying to connect to the remote browser (button to connect) using the tutorial as a guide I get an error message" Smartftp has caused an error in USER.EXE smartftp will now close"

#3 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 04 April 2006 - 03:27 PM

pkla: I have tested SmartFTP 2.0.996 on Windows 98 SE and I couldn't find any problems. However I'm unable to test it on Windows ME.

I guess it's time to update your 8 year old OS.

Regards,
SmartFTP

#4 Roy

Roy
  • Members
  • 1 posts

Posted 07 June 2006 - 03:08 PM

It appears that 'pkla' is not the only one with the connection problem :unsure: ...

I'm using SmartFTP 2.0.996 for the first time -- Every time I try to connect to a remote site, I also get the error in the USER.exe and the program closes ... Upon trying to access another icon on my desktop, I get the infamous BLUE SCREEN and I'm require to reboot ...

BTW, I'm using WIN98SE and will not attempt to upgrade to any of the XP systems -- waiting for the newer "more secure" :rolleyes: OS that is due out , NOW, next year ...

Can you help??

#5 krustybrandmaf

krustybrandmaf
  • Members
  • 5 posts

Posted 13 July 2006 - 01:57 PM

I just wish I could find a reliable download link to the latest version. I followed the link from the SmartFTP site and ended up with version 2.0.996.36 instead of 2.0.996.42 :unsure:

#6 eyebex

eyebex
  • Licensed User
  • 1860 posts
  • Gender:
    Male

Posted 13 July 2006 - 02:47 PM

Use the link from my footer below ...

#7 krustybrandmaf

krustybrandmaf
  • Members
  • 5 posts

Posted 15 July 2006 - 02:33 PM

Use the link from my footer below ...


Thanks very much :unsure:

#8 Lost in Italy

Lost in Italy
  • Members
  • 1 posts

Posted 04 November 2006 - 07:37 PM

Hi

The install program for 2.0.999.21 (x86) comes up with a dialogue box saying that the installer doesn't work with Windows 95 or NT4. What have we NT4 users done to offend you?

#9 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 04 November 2006 - 10:44 PM

NT4 is not supported anymore. Beside the fact the OS is 8 years old it contains numerous security problems for which no fix/patch is available.
Regards,
-Mat

#10 droyea

droyea
  • Members
  • 1 posts

Posted 26 November 2006 - 01:40 AM

I am another user using WinME. SmartFTP v1.0 to 1.9 used to work fine for me. I have the same issue as 'pkla'.

Ever since the forced upgrade to v2+ it has failed during an attempted connect with the message
"Smartftp has caused an error in USER.EXE. Smartftp will now close."

I've tried earlier versions of v2 up to and including v2.0.1000.2 tonight.

I've searched this forum for a solution, and have seen that there are many in the same situation as me; however, all I've seen for advice is "Update your OS". <_< Sorry, that's not something I'm willing to do for this machine.

I would be extremely grateful if I could get an explanation of this error and any suggestions on how I might fix it. I'd love to be able to use this application again.

Regards,

Dan

#11 peter hhutchison

peter hhutchison
  • Members
  • 5 posts

Posted 06 March 2007 - 08:48 PM

Use the link from my footer below ...


I am using Windows 98SE and have not had any problems until now. The Smartftp.exe version is 2.5.1004.9

I had the usual message about needing to reload. I went to the link from your post and downloaded the .exe file. I now get a message "...linked to missing file RASAPI32.DLL" and then "a device is not working". Is there anything I can do other than find a different program.

Peter Hutchison

#12 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts
  • Gender:
    Male
  • Location:
    Vitoria-Gasteiz Beyond Stargate Network ;)

Posted 06 March 2007 - 09:07 PM

SmartFTP 2.5 no longer supports windows 9x plataform. You must stay with SmartFTP 2.0 or change your OS.

#13 peter hhutchison

peter hhutchison
  • Members
  • 5 posts

Posted 11 March 2007 - 09:46 AM

SmartFTP 2.5 no longer supports windows 9x plataform. You must stay with SmartFTP 2.0 or change your OS.


I was happy with the version I had previously ( I can't remember the version) which worked OK until I had to reload it. Version 2.0 does not appear to be available to unlicenced users who need to reload.

#14 GypsyCowgirl

GypsyCowgirl
  • Members
  • 2 posts

Posted 10 July 2007 - 07:13 PM

Hello, I am using Windows XP, and cannot down SmartFTP, I get an error message stating there is an error due to c:\windows\system32\advpack.dll

#15 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 11 July 2007 - 12:17 AM

Hello ..

Try the following setup:
http://www.smartftp....get/SFTPNSI.exe

Regards,
SmartFTP

#16 GypsyCowgirl

GypsyCowgirl
  • Members
  • 2 posts

Posted 13 July 2007 - 05:16 PM

Hello, I am using Windows XP, and cannot down SmartFTP, I get an error message stating there is an error due to c:\windows\system32\advpack.dll



That download did not work either. I get an error message stating the source file can not be read.

#17 Mike1951

Mike1951
  • Members
  • 1 posts

Posted 09 August 2007 - 05:43 AM

Just upgraded to 2.5 and even though I selected data import, all addresses and logins were not carried forward.

ARe they lost or is there a way to retreive them?

Mike

#18 jt73

jt73
  • Members
  • 2 posts

Posted 14 August 2007 - 11:58 PM

I found and installed SmartFTP on my XP machine at home and it works great...I then decided to install it on my new laptop which runs Vista business. The installer crashes and I get this message:
An error occured installing the package. Windows installer returned '1625'.

I noticed that it is vista certified, but I dont see any posts from people running vista. Does anyone have any ideas on how I can get this to install on my machine?

Thanks,
JT

#19 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 15 August 2007 - 01:10 AM

Hello ..

Thats weird. Please try to install it from the following setup:
http://www.smartftp....get/SFTPNSI.exe

Regards,
Mat
SmartFTP

#20 jt73

jt73
  • Members
  • 2 posts

Posted 16 August 2007 - 12:09 AM

Hello ..

Thats weird. Please try to install it from the following setup:
http://www.smartftp....get/SFTPNSI.exe

Regards,
Mat
SmartFTP


Mat,
That worked great, thanks for the assistance and the link. Problem solved <_<

JT




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users