Jump to content


Photo

Help! - How do I chmod files?


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 vision2004

vision2004
  • Members
  • 26 posts

Posted 11 September 2004 - 09:21 PM

I watched the flash tutorial but found my FTP software different ie
I have Commands-Properties not Commands-Properties/Chmod as in tutorial, plus when highlighting the file I don't get permissions box appearing.

What am I missing?

SmartFTP v10981
Key no - 400002060

Thanks,
Herman

#2 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts

Posted 11 September 2004 - 10:40 PM

Hi.

Try selecting the desired item and use the F7 key, also instead F7 you can right click properties/CHMOD.

#3 vision2004

vision2004
  • Members
  • 26 posts

Posted 11 September 2004 - 11:29 PM

Thanks....I found out thru trial and error one can only chmod the remote files not local ones...correct?

#4 eyebex

eyebex
  • Licensed User
  • 1860 posts

Posted 12 September 2004 - 01:39 AM

yes, correct. chmod changes the unix mode bits to access a file (most ftp servers run under a unix operating system; in fact "chmod" is a native unix command). as smartftp runs under windows which has a completely different file access permission scheme, chmod is not applicable. just out of curiosity, why were you trying to change the access permissions of a local file?

#5 vision2004

vision2004
  • Members
  • 26 posts

Posted 12 September 2004 - 02:30 AM

Thanks for the feedback!

why were you trying to change the access permissions of a local file?


Simply didn't know permissions only apply to remote files.

Questions: After setting permissions to 666 can they revert back to 644 of their own accord? ( I seem to be getting this problem).

#6 eyebex

eyebex
  • Licensed User
  • 1860 posts

Posted 12 September 2004 - 11:52 AM

After setting permissions to 666 can they revert back to 644 of their own accord? ( I seem to be getting this problem).

One possible reason for this may be: The server you're connection to just simulates the Unix mode bits, because in fact the server runs under Windows. An example for such a server is FileZilla. It just displays "dummy" mode bits, but you can't modify them. Take a look at the status messages to identify the server software used (this is mostly printed in the beginning) or any error messages that may indicate simulated mode bits like
   SITE CHMOD 664 VISWOM.log

500 Syntax error, command unrecognized.


#7 vision2004

vision2004
  • Members
  • 26 posts

Posted 13 September 2004 - 01:24 AM

Thanks for the feedback

I have another problem:

I get this error when trying to set permissions to 755 for a php script I am trying to upload. The current permissions for the script are set at 0 (I can't get it to change).

Please advise

Herman

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 13 September 2004 - 02:07 AM

There is no need to change the file permissions of a .php file to make it executable.

-Mat