Jump to content


Photo

Illegal Operation


  • Please log in to reply
5 replies to this topic

#1 chinacat

chinacat
  • Members
  • 1 posts

Posted 01 September 2004 - 11:41 AM

I keep getting the "This Progarm Has Performed an Illegal Operation Error and Will Shut Down" error. I am running Win98 which was recently re-installed. I had used SmartFTP succesfully for a for couple years previously prior to the re-install. Here are the details behind the error:

SMARTFTP caused an exception 03H in module KERNEL32.DLL at 0177:bff768a5.
Registers:
EAX=c0030000 CS=0177 EIP=bff768a5 EFLGS=00000246
EBX=00000000 SS=017f ESP=007d9e74 EBP=007d9e98
ECX=fffffff1 DS=017f ESI=81647990 FS=3dd7
EDX=00000000 ES=017f EDI=81646f38 GS=0000
Bytes at CS:EIP:
c3 cc cc 55 8b ec 56 57 68 c0 94 fc bf e8 01 d9
Stack dump:
0285326d 0285cadc 7fffffff 00001d5b 00000000 0234b7a7 00000000 007d9e9c 0244f024 007d9ec4 02853412 007d9f48 007d9fc0 02349a4c 00000000 00000000

HELP!

#2 FTPUser11

FTPUser11
  • Members
  • 1 posts

Posted 02 September 2004 - 12:17 AM

I receive the same exact problem. I'm running Windows 98 SE.

#3 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 September 2004 - 01:03 AM

There seems to be a problem with Windows 98 SE and the latest SmartFTP build 1.0.982.

We will fix it asap.

Thanks for your patience.

-Mat
SmartFTP.com

#4 stengun

stengun
  • Members
  • 6 posts

Posted 02 September 2004 - 10:40 PM

I have used SmartFTP since version 1.0.980 and have had good results until I upgraded to ver. 1.0.982 - in the Danish version of Windows 98SE.

I too received exactly the same problem and message.

I even tried - uninstalling ver. 1.0.982 an reinstalled ver. 1.0.981 with the same result. I therefore believe it have somthing to do with interaction with some of the system files. Some of these have been upgraded since the introduction of ver. 1.0.981, due to releases of Microsoft Security Upgrades.

Underneath I have copied my systeminfo and error message:

Sytem Info:

+- System -----------------------------

Microsoft Windows 98 SE

Total Memory : 523660 KB
Free Memory : 198384 KB

+- SmartFTP ---------------------------

Version : 1.0.982.12
Time Stamp : 2004-08-30 17:18:15

+- Application DLL --------------------

controls.dll : 1.6.982.12
ftpapi.dll : 2.0.982.12
language.dll : 1.0.982.12
reseng.dll : 1.3.982.12
smarthook.dll : 1.0.2.1

+- System DLL -------------------------

unicows.dll : 1.0.4018.0
shell32.dll : 4.72.3812.600
shlwapi.dll : 6.00.2800.1552
comctl32.dll : 5.81
riched20.dll : 5.30.23.1200
schannel.dll : 5.00.1878.13

+- Internet Explorer ------------------

Version : 6.0.2800.1106

+- Winsock ----------------------------

Winsock : 2.2


Traslated error message:

The program has performed an illegal action and is terminated.

Contact the program-dealer, if the problem continious.

Details>>:

SMARTFTP has caused an exception 03H in modul KERNEL32.DLL on the adress 0197:bff768a1.
The contents of the protocols:
EAX=00000002 CS=0197 EIP=bff768a1 EFLGS=00000246
EBX=00000000 SS=019f ESP=007de5b4 EBP=007de5d8
ECX=fffffff1 DS=019f ESI=81d873a4 FS=1897
EDX=00000000 ES=019f EDI=81d44da8 GS=0000
Byte at CS:EIP:
c3 cc cc 55 8b ec 56 57 68 c0 94 fc bf e8 01 d9
The contents of the stack:
0285326d 0285cadc 7fffffff 00000bd7 00000000 028ebc67 00000000 007de5dc 029ef024 007de604 02853412 007de688 007de700 028eb090 00000000 00000000


I hope this can help resolving/narrowing down the problem.

#5 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts
  • Gender:
    Male
  • Location:
    Vitoria-Gasteiz Beyond Stargate Network ;)

Posted 02 September 2004 - 10:53 PM

Try to download the last Development build, it must fix your trouble.

#6 stengun

stengun
  • Members
  • 6 posts

Posted 24 September 2004 - 10:41 AM

I must admit, that when You say ASAP you mean it! Only 2 days to solve the problem - I am amazed.

Would every other developers - at other products - be just nearly as quick as this, life would be bright and easy.

I must compliment You and Your team. Thank You! - It did solve the problem!
Even though it is some days ago since You responded and solved the problem (Better later than never).


Later on I have installed a non-English languagepacket. Here it seems that there is a problem with the userinterfaces under setting/Connection/Proxy where the layot of page isn't the same as in the English language packet. The problem could be caused by the fact that I have installed Dev.-ver. 1.0.982.18 and the language packet is for ver. 1.0.982.17. The problem isn't a major and has been reported to the corresponding project Team.

From a satified User!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users