Jump to content


Photo

TLS prior to logon


  • Please log in to reply
4 replies to this topic

#1 random456

random456
  • Members
  • 1 posts

Posted 12 June 2004 - 10:59 PM

I am trying to connect to a ftp server that requires AUTH TLS before USER and PASS. Is there an option to create this behavior?

This is the error I get from the server:

421 TLS session MUST be engaged


another question: If I am understanding this correctly, isn't a little insecure to activate encryption after a cleartext username and password have been sent?

#2 gusto

gusto
  • Members
  • 1 posts

Posted 31 July 2004 - 08:03 PM

I need this too.
Cant use smartftp to connect to glftpd+tls
It worked in flashfxp.

Here is wat I get when trying to connect with smartftp:

220 Alfred (glftpd 1.32_Linux+TLS) ready.

    USER notvalid

530 User notvalid access denied. Use secure access


With flashfxp I get this:

220 Alfred (glftpd 1.32_Linux+TLS) ready.

AUTH SSL

234 AUTH SSL successful

Negotiating SSL/TLS session...

SSL/TLS negotiation successful...

SSL/TLS connection using cipher ***-***-***-***-*** (168 bits)

PBSZ 0

200 PBSZ 0 successful

USER notvalid

331 Password required for notvalid.

PASS (hidden)

230 User notvalid logged in.


#3 digge

digge
  • Members
  • 5 posts

Posted 07 September 2004 - 09:22 AM

I have the same problem. Seems SmartFTP never sends the AUTH command but just goes on straigt to USER. Even though i tried every single setting i could find that should enable tls.

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 07 September 2004 - 02:27 PM

There is a button on the right side of "Address:" label in the URL toolbar. Select "FTP over SSL (Explicit)".

The better way would be to add a favorite and change the protocol in the favorite item settings.

The howtos explain how to connect to a SSL/TLS enabled server.
http://www.smartftp.com/support/howto

-Mat
SmartFTP.com

#5 fireseven

fireseven
  • Members
  • 1 posts

Posted 13 July 2005 - 10:31 PM

I've read through as much help as I could find that seemed related to this issue.

I am a glftpd TLS site admin with no luck in connecting when TLS is enabled.

FlashFXP connects via TLS just fine.

Please fix this bug!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users