Jump to content


Photo

File view never correct


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 jma

jma
  • Members
  • 3 posts

Posted 07 June 2004 - 04:08 AM

I use SmartFTP to transfer files from home to work and back again. It is a great product, but I'm having one major difficulty with it. When used from home it never gets the files correct. The FTP site is a work address, and the file listing is correct when at work, but not at home.

Let me try to describe the two major problems I have:

* The files it shows in the root folder seem recursive down the first path. So as an example, if this is my tree:

ftp.myftp.com

   + foo

      - bar.c

When I first connect, I see the "foo" folder, but also "bar.c" inside the root folder, when I shouldn't see it at all. If I try to delete, download, etc, it gives me errors (of course) because the file isn't there.

* After uploading files from home, if I disconnect and then reconnect, the file listing only gives me the files from the first folder in the root folder, and I can't see anything else. Using the above example, all I would see is:

ftp.myftp.com

   - bar.c

Now, if I launch SmartFTP from work and look, everything looks just as it should. I sincerely hope this is just a silly user setting on my part causing this. I don't know if perhaps it is a caching issue? Any advice is welcome. Thanks.

One last minor inconvenience (again, from the home side) is that I can't drag and drop from the ftp site to a local folder. I can do this at work just fine, but not from home. The drag appears to work, but when I got to that folder, there is just an empty folder named "SOFTDRP" or something along those lines (sorry, not at home right now to test).

Thanks again,
Jeff

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 07 June 2004 - 07:56 AM

Please post your license key (without the signature) for Premium Support.

Thank you.
SmartFTP.com

#3 jma

jma
  • Members
  • 3 posts

Posted 07 June 2004 - 12:11 PM

-----BEGIN KEY-----
ID: 400005497
User: Jeffrey Massung
Company:
Email: jma@insightbb.com
Version: 1.0
Number: 1
Date of Issue: 2004-05-24
Maintenance Expiration: 2005-05-24
-----BEGIN SIGNATURE-----

#4 jma

jma
  • Members
  • 3 posts

Posted 08 June 2004 - 04:22 AM

Just to give an example of what I'm talking about, here are two images, one showing a DOS window connected to the site in the root dir and DIR listings for it and the first sub-folder (bank). Below it is a screenshot of smartftp immediately after connecting to the same server.

http://www.jm-basic....images/real.gif
http://www.jm-basic....es/smartftp.gif

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 June 2004 - 01:23 PM

Go to Menu: Settings->Transfer
and in the "Directory Listing Options"
disable the Recusive -R option.

If you are connecting over a favorite disable it the favorite item settings.

Regards,
-Mat
SmartFTP.com