Jump to content


Photo

Missing files when uploading directories


This topic has been archived. This means that you cannot reply to this topic.
25 replies to this topic

#21 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 29 March 2004 - 11:12 PM

Do you have the same problem when having the global cache disabled?
Settings->Cache

If you are using a favorite make sure you disable the cache in the favorite settings as well.

-Mat
SmartFTP.com

#22 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 30 March 2004 - 04:32 AM

Please check the latest developer build:
http://www.smartftp....get/SFTPDev.exe

SmartFTP wont longer restore the directory after an error occured. This way you can better see (without scrolling up) what caused the problem.

Please check this build and try again. All upload failures have been caused by a server timeout on my side. Increasing the server timeout should at least fix this problem.

-Mat
SmartFTP.com

#23 [Unknown]

[Unknown]
  • Members
  • 3 posts

Posted 30 March 2004 - 05:07 PM

I'm not having the problem, but... I would suggest that if SmartFTP cannot upload something and another client can, even if it is caused by server issues or connection problems, this is something SmartFTP should try to get on top of - I would say this is in the class of what Mozilla calls "Bugs that make Mozilla look bad".

While I am a developer myself, and understand that it's hard to fix issues you have no reproducable test case for, I feel that you're being a bit unneccessarily cold about this issue. If it helps, I'll repost this as a feature request - either way, I really do think it is a priority issue, because I happen to know you're losing not only current users but even potential clients solely because of this issue.

Example of someone asking for a new FTP client on our forum:
http://www.simplemac...hp?topic=8513.0

-[Unknown]

#24 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 30 March 2004 - 05:32 PM

Hello ...

If you have read the thread carefully enough, you should have noticted that we have suggested a solution/workaround for this problem. Simply using the global queue will solve all of the upload problems (server timeout, disconnects, etc) the users are encountering here.

Furthermore there will be always users unable to upload due to problems with their configuration, system, router, remote server, etc and SmartFTP cannot solve all of their problems. And blaming the software without any evidence is not the way to go.

-Mat
SmartFTP.com

#25 zPiranha

zPiranha
  • Members
  • 5 posts

Posted 30 March 2004 - 10:01 PM

mb: I believe Unknown is right. Just because you can't reproduce it doesn't mean the bug doesn't exist. You're not always right as the developer.

I am actually considering a new FTP client myself, this bug bothers me so much.

I believe that the solution is not suggesting something that's slightly more difficult, it's tracking down the bug and fixing it.

#26 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 31 March 2004 - 12:50 AM

This thread is closed.

All serious bug reports can be sent in the correct form to bugreport attt smartftp.com

All other kind of flames, wrong statements and accuses etc. are not welcome anymore. Thank you.

-Mat