Jump to content


Photo

Application HANG on Folder Views


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 dsimoes

dsimoes
  • Members
  • 1 posts

Posted 05 March 2004 - 01:59 AM

Hi !

I recently downloaded SmartFTP which i must say very nice work with UPNP features.

Ok, here's the problem. To make a download/upload and selection destination/source folter/files works just fine but when i select a Folder View the application hangs at 100% CPU Usage.
I decided to wait, and after around 2 mins it will show up my folders/drives.
After that i clicked on for ie. C: resulted in another 2 mins then i can work around folders on c: it will not hang.

The default folder that "Local Browser" window was openning was the "desktop" ( with all computer drives and all ) so i tried to force it to open a specific folder like c:dir, i did manage to make that change ( again with it hanging) but, even openning a new "Local Browser" window on that specific dir it will hang :) .

I also thought it could be a network drive i had, but i disconnected it and no good.

OS: Windows XP Pro with SP1 and P4 with HT enabled.

Hope this helps and you guys can nail the problem.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 05 March 2004 - 03:02 AM

It's hard to tell what causes this problem. And even harder to debug/fix.
It might be a shell extension which gets loaded when a Localbrowser window is opened. Or a device in the MyComputer tree which is not connected.

If you're interested we can go with a remote debug session. But it takes at least 1-2h and you need at least a broadband connection.

You can contact me over bugreport atttttttttt smartftp.com

Thanks
-Mat