Jump to content


Photo

Problems behind proxy


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 vxupkr

vxupkr
  • Members
  • 3 posts

Posted 15 December 2003 - 01:07 PM

After installing the latest build ( then dev. build 1.0.980 ) the software can connect via proxy at the specified port however then trying to list the directories at different ports that are not allowed. Same with Pasv or Active mode.

Connecting to Proxy (10.23.5.253) -> IP: 10.23.5.253 PORT: 2370
Connected to Proxy (10.23.5.253) -> Time = 0ms
Socket connected waiting for login sequence.
220 FTP proxy (v0.13.1) ready
USER anonymous@ftp.sunet.se:21
331-####################################################################
331-### Try accessing us on the World Wide Web! http://ftp.sunet.se/ ###
331-### ###
331-### http://ftp.sunet.se/pub/ to browse... ###
331-### ###
331-### http://ftp.sunet.se:8000/ftpsearch to search for filenames ###
331-### ###
331-### http://ftp.sunet.se/mnogo/search.php to freetext search ###
331-### ###
331-####################################################################
331-
331--> Please login with user anonymous or ftp to access our archive <-
331-
331 Please specify the password.
PASS (hidden)
230 Login successful. Have fun.
SYST
215 UNIX Type: L8
FEAT
500 Unknown command.
REST 100
350 Restart position accepted (100).
REST 0
350 Restart position accepted (0).
PWD
257 "/"
TYPE A
200 Type set to A
PASV
227 Entering Passive Mode (10,23,5,253,231,219)
Opening data connection IP: 10,23,5,253,231,219 PORT: 59355.


Licensing info:
ID: 400002193
User: Pavel Hassmann

#2 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 15 December 2003 - 06:24 PM

Hello ..

For the PASV mode problem please go to
Menu: Tools->Settings->Connection : "Data Connection"
and enable the "Force Server IP for PASV" checkbox.

Then try again. Please send the log again.

Regards,
SmartFTP.com

#3 vxupkr

vxupkr
  • Members
  • 3 posts

Posted 16 December 2003 - 06:40 AM

I

#4 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 16 December 2003 - 07:06 AM

Hello.

Did you also check the setting in the favorite properites if you're connecting over a favorite?

-Mat

#5 vxupkr

vxupkr
  • Members
  • 3 posts

Posted 16 December 2003 - 02:17 PM

Did not connect trough favourite...

#6 mb

mb

    Developer

  • Administrators
  • 11520 posts

Posted 22 December 2003 - 08:57 PM

Hello...

The problem is with your FTP proxy.

SmartFTP does not overwrite the IP in the PASV command reply when connecting through a proxy even if the "Force Server IP for PASV Mode" is enabled in the settings. This is the right behavior.

Regards,
-Mat
SmartFTP.com