Jump to content


Photo

Year displayed incorrectly in remote window


This topic has been archived. This means that you cannot reply to this topic.
7 replies to this topic

#1 mr slim

mr slim
  • Members
  • 11 posts

Posted 04 November 2003 - 02:51 AM

This was addressed recently in the Users Helping Users forum in the following topic:

http://smartftp.com/...5162&highlight=

As it's something of a problem, I think reporting it as a bug is appropriate.

More detail is there, but to sum it up, on servers that don't provide a year in the raw listing, SmartFTP apparently "guesses" based on the time relative to the current time.

To quote Mat from that thread:

>For dates without a year in the listing the following rule applies:
>
>If date in listing is in the future: Year = Current Year - 1
>There's some +- here (about 6 hours) because the FTP server may be in a different time zone.
>
>If date is in the past: Year = Current Year
>
>That's the reason the year is not always correct. If you have a better idea how to solve this "missing year in date" problem pelase let me know.

My server's timezone is GMT. I'm PST, so there's an 8 hour difference. That means that between 16:00 and 00:00 my time, I see all newly uploaded files to my server having the proper timestamp GMT EXCEPT that the year is 2002 instead of 2003.

I understand the dilemma, but literally every other ftp client I've tried this on is able to display the year correctly. Many of these clients are considerably less sophisticated than SmartFTP. If I display the contents of the directory in my browser window, the year is correct there, too.

My host says that eventually, they'll output the year, but they don't know when.

There must be some way to address this since other programs do. Perhaps test more specifically for the future date. If the date of the file is more than 24 hours into the future, then use your current formula, otherwise, give the file on the server the current year is one simple thing that comes to mind that has its flaws, but would be more accurate than the current approach.

Otherwise, I very much appreciate the good work and enjoy using SmartFTP.

BTW, I'm not including system info because the issue was already confirmed in the post indicated above. That information is there if you'd like to see it.

#2 mr slim

mr slim
  • Members
  • 11 posts

Posted 04 November 2003 - 02:54 AM

As of today, my host has changed their raw listing to another format completely that includes the year, so I no longer have the problem I described with the site where it matters most to me. But it would still surface in some other sites and I've seen that other people have seen the same thing.

Hope this is of some use and that it can be addressed to tighten up an already fine ftp client.

#3 Louie

Louie
  • Members
  • 337 posts

Posted 29 November 2003 - 09:51 AM

Thanks for sharing, much appreciated!

#4 mr slim

mr slim
  • Members
  • 11 posts

Posted 25 January 2004 - 07:47 AM

Sorry to have to reawaken this issue that nobody seems to want to address, but here goes...

My host, which had temporarily changed its ftp server to one that sent out raw data that included the year, has changed back to one (proftpd, I think) that doesn't. So SmartFTP once again displays the wrong year in the remote directory when I upload a file to it.

I'm in PST and the server's time is GMT, so when I upload after 16:00 up until midnight, the remote directory shows a year of 2003 instead of 2004.

I appreciate the explanation offered that since there's no raw data providing a year, that the only option is for SmartFTP to display the prior year when the date stamp on the remote file is later than the current one.

BUT, every other ftp program or browser window view of my remote directories shows the correct year under these circumstances. I've probably tried ten different programs/browsers to see what they do.

So it strikes me that they must have a way to effectively deal with this. I'd mentioned earlier in the thread that one possible approach would be to show the current year when the remote file is prior to the current date, on the current date, or within 24 hours in advance of the current timestamp. That way, a file uploaded at 20:00 to a server that's at 06:00 the next day would show the current year instead of the prior one.

Or whatever might work.

Excuse my rant here. If I were down on SmartFTP, I'd just go elsewhere. Yes, the fact that the program is free is a point in its favor with respect to going to a different client, but there are other free ones, too, that display the right year.

I suppose I could always change my host. :wink:

Anyway, others must be having this problem, too, and I hope the feedback is worth something to you.

#5 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 07 February 2004 - 03:00 PM

Hello ..

Try the latest developer build: 1.980.13
http://www.smartftp....get/SFTPDev.exe

I've changed the algo to calculate the year.

Regards,
-Mat
SmartFTP.com

#6 mr slim

mr slim
  • Members
  • 11 posts

Posted 07 February 2004 - 06:07 PM

Thanks so much for this. I'll let you know what effect it has on my issue later in the day when the times bring it into play.

#7 mr slim

mr slim
  • Members
  • 11 posts

Posted 08 February 2004 - 12:16 AM

The change in the date algorithm are having the effect I was hoping for. Thanks so much, once again, Mat. Much appreciated.

#8 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 08 February 2004 - 04:12 PM

You're welcome. Thanks for your exlusive bug report ;)

-Mat
SmartFTP.com