Jump to content


Photo

Imlicit SSL via the favorite menu and Global Queue


This topic has been archived. This means that you cannot reply to this topic.
4 replies to this topic

#1 vipwolf

vipwolf
  • Members
  • 5 posts

Posted 23 September 2003 - 09:19 AM

Bug:

When I connect to a server using the favorites that uses FTP over SSL (implicit) I can browse and download from the server. If I try to put some of the files in my global queue it will try to connect using the implict SSL Mode but using port 990 not the port I saved with my favorites. Same problem if try to upload to the server using the global queue. Source queue works fine though, so I know its not a server problem.

Swichting to explicit mode is not an option as the server only supports implicit.

Also I followed LMs advice:
"This is not a bug. The problem is that the "Implicit-SSL Mode" is not
supported via Global Queue, unless you add the site to your favorites.

So basically connect to the site from the favorites, then add the
items to the Global Queue, and perform your upload/download(s)."

I still think its a bug as I dont see why supporting all modes but implict ssl via the global queue is a feature. I dont think you should fix everything immediatly but still you should notice it as a bug, as you did when the problem was stated for the first time with version 1.0.973.

I hope the thread will not be moved to some other part of the forum, as this realy is a bug.

Kind regards Ben

+- System -----------------------------

Microsoft Windows XP Professional
Service Pack 1 (Build 2600)

CPU Speed : 1526 MHz
Total Memory : 523760 KB
Free Memory : 295500 KB

+- SmartFTP ---------------------------

Version : 1.0.979.1
Time Stamp : 2003-09-17 13:37:55

+- Application DLL --------------------

controls.dll : 1.6.979.1
ftpapi.dll : 2.0.979.1
language.dll : 1.0.979.1
reseng.dll : 1.3.979.1
smarthook.dll : 1.0.2.1

+- System DLL -------------------------

shell32.dll : 6.00.2800.1233 (xpsp2.030604-1804)
shlwapi.dll : 6.00.2800.1226
comctl32.dll : 6.0 (xpsp1.020828-1920)
riched20.dll : 5.30.23.1211
schannel.dll : 5.1.2600.1106 (xpsp1.020828-1920)

+- Internet Explorer ------------------

Version : 6.0.2800.1106

+- Winsock ----------------------------

Winsock : 2.2

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 23 September 2003 - 06:57 PM

It's a known problem that the global queue doesn't support implicit SSL if you don't connect from/over a favorite item.

But the easiest workaround is to create a favorite for your site (its recommended anyway) then connect to the server and add the files to the queue.

Regards,
-Mat
SmartFTP.com

#3 vipwolf

vipwolf
  • Members
  • 5 posts

Posted 25 September 2003 - 01:08 PM

It's a known problem that the global queue doesn't support implicit SSL if you don't connect from/over a favorite item.

But the easiest workaround is to create a favorite for your site (its recommended anyway) then connect to the server and add the files to the queue.

Regards,
-Mat
SmartFTP.com


I did exactly that but in the global queue it forgets which port I use for that site. It will now try to do implicit SSL but it does so using port 990 instead of port 21 that is saved with the favorit

#4 Louie

Louie
  • Members
  • 337 posts

Posted 25 September 2003 - 02:26 PM

I can reproduce the bug, thank you for reporting!

But you may also want to take a look at the following info:
http://www.ford-hutc...ps-ext.html#bad

#5 Louie

Louie
  • Members
  • 337 posts

Posted 25 September 2003 - 06:28 PM

Bug fixed, please grab the latest dev. build.
http://www.smartftp....get/SFTPDev.exe