Jump to content


Photo

Auto port mode


This topic has been archived. This means that you cannot reply to this topic.
10 replies to this topic

#1 succo

succo
  • Members
  • 40 posts

Posted 14 September 2003 - 09:38 AM

am i wrong or the auto ip in port mode stopped working in the latest builds?
i had to switch back to .978 to make it work
bye

#2 Louie

Louie
  • Members
  • 337 posts

Posted 14 September 2003 - 10:58 AM

Confirmed!

Seems to be broken, works if you are behind a UPNP router setup.
Because it uses the " GetExternalIPAddress" function.

But will not work if on a non UPNP router setup.
Which uses the "IP Repeater" function.

Thanks for bug-report.

#3 Louie

Louie
  • Members
  • 337 posts

Posted 14 September 2003 - 12:05 PM

It's now fixed, please grab the latest dev. build.

#4 succo

succo
  • Members
  • 40 posts

Posted 14 September 2003 - 01:02 PM

mmmmmmmh... no go
still no 'connecting to repeater', only the private ip

SmartFTP Developer build 1.0.979.0 14.09.2003 14:04:32

#5 Louie

Louie
  • Members
  • 337 posts

Posted 14 September 2003 - 01:19 PM

It's working here.

#6 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts

Posted 14 September 2003 - 01:20 PM

Here too

[15:18:32] 200 Type set to A.
[15:18:32] Connecting IP Repeater "repeater.smartftp.com" ...
[15:18:32] IP Repeater returned: "217.127.xxx.xxx"
[15:18:32] PORT 217,127,xxx,xxx,12,43
[15:18:33] 200 PORT command successful.
[15:18:33] Opening data connection IP: 217.127.xxx.xxx PORT: 3115.

#7 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 14 September 2003 - 01:24 PM

The IP Repeater is only connected when you make a connection to a host server on a non default port (not equal to 21) or on a SSL/TLS connection and if the host IP is not in the private range.

-Mat

#8 succo

succo
  • Members
  • 40 posts

Posted 14 September 2003 - 01:45 PM

strange...
i made it work only putting in 'manual' my no-ip and using manual in favorites
don't know why it doesn't work

#9 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 14 September 2003 - 02:05 PM

Aha.

Thanks for your answer. But it doesnt help much to confirm whether the problem has been fixed or not.

-Mat

#10 succo

succo
  • Members
  • 40 posts

Posted 14 September 2003 - 06:13 PM

wel, the quick answer is 'no', sorry
put port mode and auto in general settings, moved the favorite to use general settings and it came up with local ip at port
this is my version
+- System -----------------------------



Microsoft Windows XP Professional 

Service Pack 1 (Build 2600)



CPU Speed         : 1467 MHz

Total Memory      : 523764 KB

Free Memory       : 216020 KB



+- SmartFTP ---------------------------



Version           : 1.0.979.0

Time Stamp        : 2003-09-08 16:55:26



+- Application DLL --------------------



controls.dll      : 1.6.979.0

ftpapi.dll        : 2.0.979.0

language.dll      : 1.0.979.0

reseng.dll        : 1.3.979.0

smarthook.dll     : 1.0.2.1



+- System DLL -------------------------



shell32.dll       : 6.00.2800.1233 (xpsp2.030604-1804)

shlwapi.dll       : 6.00.2800.1226

comctl32.dll      : 6.0 (xpsp1.020828-1920)

riched20.dll      : 5.30.23.1211

schannel.dll      : 5.1.2600.1106 (xpsp1.020828-1920)



+- Internet Explorer ------------------



Version           : 6.0.2800.1106



+- Winsock ----------------------------



Winsock           : 2.2


#11 mb

mb

    Developer

  • Administrators
  • 11527 posts

Posted 14 September 2003 - 07:32 PM

It's fixed.

Thread closed.

-Mat