Jump to content


Photo

FTP/SSL in Active Mode connections


This topic has been archived. This means that you cannot reply to this topic.
5 replies to this topic

#1 mantovani

mantovani
  • Members
  • 3 posts

Posted 26 August 2003 - 05:59 PM

Simply: ACTIVE (PORT) worked with build 976, it does not work anymore with build 978.

With 976:
PROT P
200 Prot set to P
PORT 192,168,0,1,16,66
200 Port command successful
Opening data connection IP: 192.168.0.1 PORT: 4162.
LIST -aL
150 Opening ASCII SSL data connection for directory list
Connected. Exchanging encryption keys...
Session Cipher: 128 bit RC4
SSL encrypted session established.
57 bytes received successfully. (57 B/s) (00:00:01).
226 Transfer complete

With 978:
PROT P
200 Prot set to P
PORT 192,168,0,1,16,83
200 Port command successful
Opening data connection IP: 192.168.0.1 PORT: 4179.
LIST -aL
150 Opening ASCII SSL data connection for directory list
0 bytes received successfully. (0 B/s) (00:00:01).
425 Can't open data connection

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 27 August 2003 - 12:48 AM

Do you run both versions of SmartFTP in parallel?

-Mat

#3 mantovani

mantovani
  • Members
  • 3 posts

Posted 27 August 2003 - 09:29 AM

Hi Mat,
no, I don't.

Before trying each version I uninstall the previous one from control panel -> add/remove programs.

I'm using W2000 sp4 ITalian.

I dowloaded 978 from your website for evaluation (a friend told me to try a nice ftp program ;) ), installed it, but it didn't work with ACTIVE (PORT) SSL explicit connections.
My friend told me that he was not having problems, so we checked the version and we found he was using 976.
So I tried 976 after uninstalling 978, and actually 976 works.

I thought useful to report it to you.

May I help you in some other way?

Leo

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 29 August 2003 - 12:40 AM

The bug has been fixed in the latest developer build:
http://www.smartftp....get/SFTPDev.exe

Thanks for your time.
-Mat
SmartFTP.com

#5 mantovani

mantovani
  • Members
  • 3 posts

Posted 01 September 2003 - 06:48 PM

Hi Mat,
I confirm you that it works.

Really nice ftp program, however it seems to me that it's missing the possibility to save options/settings individually for each site, which is in my opinion a must for a ftp program.
Or may be I overlooked it ;)

Leo

#6 Louie

Louie
  • Members
  • 337 posts

Posted 01 September 2003 - 08:59 PM

Hi Mat,
I confirm you that it works.

Really nice ftp program, however it seems to me that it's missing the possibility to save options/settings individually for each site, which is in my opinion a must for a ftp program.
Or may be I overlooked it ;)

Leo


1. Thank you for confirming the bug fix.

2. Each site can have there own setting, by adding the site to your favorites.
Then simply edit the favorite site, and customize the favorite to your desire.