Jump to content


Photo

Global Queue items now properly use the favorite setting ???


  • Please log in to reply
No replies to this topic

#1 Arjan

Arjan
  • Members
  • 1 posts
  • Location:
    Netherlands

Posted 22 July 2003 - 08:36 AM

The purpose of the following scenario is to transfer files on a daily basis, by using Microsoft's scheduler.

The batch file, called by the scheduler, contains registry settings for SmartFTP.
[HKEY_CURRENT_USERSoftwareSmartFTPQueue]

"Auto Start"=dword:00000001

"On Transfer Complete"=dword:0000002

"Last File"="C:Documents and SettingsAdministrator.AVMy Documentsav.que"
These settings are read by SmartFTP (verified by REGMON), which tells SmartFTP to start the queue av.que on startup, and when the queue becomes empty the program should stop (On Transfer Complete = 2 ).

Next, the batch makes a copy of a preset queue file to av.que
Then the batch starts up SmartFTP.

Where the Auto Start = 1 is effective (the files in av.que are transferred), the On Transfer Complete = 2 is NOT effective to the program.
In stead, the SmartFTP queue is left in IDLE state.
Setting On Transfer Complete = 1 ( stop queue, after empty) does work , but that is not what I want!

Before I decide to get a license for SmartFTP, I would like to have a statement from you.
a) Should this scenario be able to work, or
;) am I mistaken, and it is SmartFTP's intention NOT to work like this ?

In case of a), :D do we get a fix for this ?
In case of :lol: , :evil: I will not buy a license.

Thanks for reading this, Arjan van de Velde (SVB, Netherlands)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users