Jump to content


Photo

URL encoding issue


This topic has been archived. This means that you cannot reply to this topic.
12 replies to this topic

#1 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 11 July 2003 - 12:02 AM

When the server directory contains "%" character( used in many non-english language), the navigation is ok but the dragged queue items
are unable to process,the log just showed" Permission Denied".
For example: %AC%EE%A4%A7%A6%5E%BE%D0

I am using the newest dev build :
Version : 1.0.978.1
Time Stamp : 2003-07-09 13:45:32

PLease help,thanks a lot!

Lupin

#2 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 17 July 2003 - 05:29 AM

Please try to fix it,thanks

#3 Caleb

Caleb
  • Members
  • 73 posts

Posted 20 July 2003 - 04:32 PM

I think you are talking about URL Encoded paths ?

This is a string in which all non-alphanumeric characters except -_. have been replaced with a percent (%) sign followed by two hex digits and spaces encoded as plus (+) signs. It is encoded the same way that the posted data from a WWW form is encoded, that is the same way as in application/x-www-form-urlencoded media type.


If so.. you are correct.

I have tried paths that contain SOME url-encoded characters such as the alt+0160 which is %A0 and it worked.. for example:
/path1/%A0%A0/test%A0/

But a path which is fully urlencoded (slashes are represented as %2F) won't work.

I haven't tried them with the global queue.. just tried to use them in SmartFTP to connect to sites..

URLs that won't work:
ftp%3A%2F%2Fftp.smartftp.com%3A21%2FSmartFTP%2F
ftp://ftp.smartftp.com:21%2FSmartFTP%2F

The correct URL would be:
ftp://ftp.smartftp.com:21/SmartFTP/

#4 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 29 July 2003 - 01:52 PM

Not URl encoding,I mean REAL directories in ftp server.
Such directories are comman among non-english DBCS language
countries....

#5 Caleb

Caleb
  • Members
  • 73 posts

Posted 29 July 2003 - 04:18 PM

still, thos are special chars which are encoded.

#6 bkausbk

bkausbk
  • Translator
  • 241 posts

Posted 29 July 2003 - 04:25 PM

ftp%3A%2F%2Fftp.smartftp.com%3A21%2FSmartFTP%2F
This even don't work in interneexplorer ... it will try to open something like
ftp://ftp/ftp.smartftp.com:21/smartftp/

Not URl encoding,I mean REAL directories in ftp server.  
Such directories are comman among non-english DBCS language  
countries....


AFAIK double byte characters will not displayed as %... !

Benjamin

#7 darix

darix
  • Members
  • 181 posts

Posted 30 July 2003 - 01:08 AM

ftp://localhost:21/pub/%25%25fooo%25%25/
( ftp://localhost:21/pub/%%fooo%%/ )

i drag a file from that directory to the globalqueue and start the download and it works.

o.O

darix

+- SmartFTP ---------------------------
Version : 1.0.978.2
Time Stamp : 2003-07-10 19:55:40

#8 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 31 July 2003 - 12:50 AM

Try: /%AC%EE%A4%A7%A6%5E%BE%D0

It works in navigation mode
it FAILS if it is QUEUE item,which contains such characters

#9 darix

darix
  • Members
  • 181 posts

Posted 31 July 2003 - 02:41 AM

can you give us a server with such directory?

darix

#10 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 07 August 2003 - 07:09 AM

I have no server,just create it.

#11 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 09 August 2003 - 02:29 PM

I got the error in log
CWD /工具軟體/圖庫圖像/榮欽科技美工圖庫大全/26餐飲
501 Illegal character in argument

hope this help!

#12 mb

mb

    Developer

  • Administrators
  • 11521 posts

Posted 10 August 2003 - 12:03 AM

Go to Settings->Transfer and change the "Listing Encoding" option to ANSI.
-Mat

#13 lupin2000

lupin2000
  • Members
  • 7 posts

Posted 12 August 2003 - 03:16 AM

HI:
I have used "ANSI" for long time.
I think the problem is just a little "check routine" iniside
smartftp,but I cannot modify it by myself easily without source
codes. Please fix it,thanks a lot!
It causes many problems and lots of my friends complained about it.


Sincerely