Jump to content


Photo

PASV command failed


  • Please log in to reply
3 replies to this topic

#1 Roland-KS

Roland-KS
  • Members
  • 7 posts
  • Location:
    Kassel, Germany

Posted 11 June 2003 - 01:44 PM

PASV command failed:
Every Connection the Same Error ?

----Log-----
Resolving host name proxy.host1-ks.de...
Resolving host name ftp.smartftp.com...
Connecting to Proxy (proxy.host1-ks.de).
Connected to Proxy (proxy.host1-ks.de) -> IP: 172.168.0.11 PORT: 21.
Socket connected waiting for login sequence.
220-InterScan FTP VirusWall NT 3.51 (Proxy Mode), PASV mode, Virus scan on
220 Secure Gateway FTP server ready.
USER anonymous@ftp.smartftp.com roland.kp
331 Password required for destination user 'anonymous'.
PASS (hidden)
332 Enter Gateway Password (use the 'account <text>' or 'quote acct <text>' command to respond)
ACCT (hidden)
230-Connected to ftp.smartftp.com.
230-SmartFTP Server ready...
230-User name okay, please send complete E-mail address as password.
230 User logged in, proceed.
SYST
215 UNIX Type: L8
FEAT
500 Syntax error, command unrecognized: 'FEAT'
REST 100
502 Command not implemented
TYPE I
200 Type set to I.
REST 100
502 Command not implemented
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PASV
501 PASV command failed -- Unable to contact server
--------------------------------------------------------------

Connection with other FTP work !!!
Log from other FTP-Client:

WINSOCK.DLL: WinSock 2.0
- -
connecting to 172.168.0.11:21
Connected to 172.168.0.11 port 21
220-InterScan FTP VirusWall NT 3.51 (Proxy Mode), PASV mode, Virus scan on
220 Secure Gateway FTP server ready.
USER anonymous@ftp.smartftp.com roland.ks
331 Password required for destination user 'anonymous'.
PASS (hidden)
332 Enter Gateway Password (use the 'account <text>' or 'quote acct <text>' command to respond)
ACCT (hidden)
230-Connected to ftp.smartftp.com.
230-SmartFTP Server ready...
230-User name okay, please send complete E-mail address as password.
230 User logged in, proceed.
PWD
257 "/" is current directory.
SYST
215 UNIX Type: L8
Host type (S): UNIX (standard)
PORT 172,18,6,111,13,72
200 PORT command successful
LIST
150 Opening ASCII mode data connection for /bin/ls.
Received 245 bytes in 0.1 secs, (20.00 Kbps), transfer succeeded
226 Transfer complete.

Thanks 4 a hint
Roland

#2 Aokromes

Aokromes

    Entity From Outer Space

  • Root Admin
  • 1519 posts
  • Gender:
    Male
  • Location:
    Vitoria-Gasteiz Beyond Stargate Network ;)

Posted 11 June 2003 - 02:17 PM

Go to Settings (control+o) connection, data connection and change the mode to port, also you can too disable send FEAT command.

#3 Roland-KS

Roland-KS
  • Members
  • 7 posts
  • Location:
    Kassel, Germany

Posted 17 June 2003 - 12:59 PM

Change to Port try also Limit Port-Range - Not Working:

215 UNIX Type: L8
REST 100
502 Command not implemented
TYPE I
200 Type set to I.
REST 100
502 Command not implemented
PWD
257 "/" is current directory.
TYPE A
200 Type set to A.
PASV
501 PASV command failed -- Unable to contact server

Other SMTP-Client works fine in Active mode and Connected to ftp.smartftp.com. :?:

### other Client in Active Mode ####
PWD
257 "/" is current directory.
SYST
215 UNIX Type: L8
Host type (S): UNIX (standard)
PORT 172,18,6,111,13,72
200 PORT command successful
LIST
150 Opening ASCII mode data connection for /bin/ls.
Received 245 bytes in 0.1 secs, (20.00 Kbps), transfer succeeded
226 Transfer complete.

-Roland-

#4 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 17 June 2003 - 04:22 PM

Go to Settings->Connection
and set the Data Connection mode to "Active Mode (PORT)"

if you use a favorite do the same in the favorite item settings.

-Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users