Jump to content


Photo

MacOS X FTP Server doesn't support LIST


This topic has been archived. This means that you cannot reply to this topic.
3 replies to this topic

#1 dordal

dordal
  • Members
  • 2 posts

Posted 08 April 2003 - 07:49 PM

I just bought SmartFTP this AM, and the first server I try to connect to doesn't work. Not exactly a good omen.

Its a MacOS X server, and it appearently doesn't support the LIST command. Here is a transcript from a manual session:

bash> ftp XXX.XXX.XXX.XXX
220--------------------------------------------------------------------------------
220-This is the "Banner" message for the Mac OS X Server's FTP server process.
220--------------------------------------------------------------------------------
220-
220 QLDXS1 FTP server (Version: Mac OS X Server 10.2 - +GSSAPI) ready.
Name (XXX.XXX.XXX.XXX:dordal): qlduser
331 Password required for qlduser.
Password:
230 User qlduser logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> LIST
?Invalid command.
ftp> ls
227 Entering Passive Mode
150 Opening ASCII mode data connection for directory listing.
total 0
drwx------ 3 qlduser staff 102 Apr 7 12:56 Desktop
drwx------ 4 qlduser staff 136 Apr 7 17:44 Documents
drwx------ 18 qlduser staff 612 Apr 7 14:30 Library
drwx------ 3 qlduser staff 102 Apr 7 12:56 Movies
drwx------ 3 qlduser staff 102 Apr 7 12:56 Music
drwx------ 3 qlduser staff 102 Apr 7 12:56 Pictures
drwxr-xr-x 4 qlduser staff 136 Apr 7 12:56 Public
drwxr-xr-x 5 qlduser staff 170 Apr 7 12:56 Sites
226 Transfer complete.
ftp>

SmartFTP seems to think that is has recieved the directory listing:
227 Entering Passive Mode
Opening data connection IP: XXX.XXX.XXX.XXX PORT: 8820.
LIST -aL
150 Opening ASCII mode data connection for directory listing.
39 bytes received successfully. (39 B/s) (00:00:01).
226 Transfer complete.

Is there a way to get SmartFTP to use a command other than LIST for a directory listing? Or can it be setup to try something else if it doesn't get a directory listing?

David

#2 mb

mb

    Developer

  • Administrators
  • 11528 posts

Posted 09 April 2003 - 02:02 AM

Hello ..

Disabling the -a and/or -l does fix the problem.

Go to Menu: Tools->Settings->Transfer and disable
"Show All Files" and "Resolve Links"

close the remote window and reconnect.

Regards,
Mathias Berchtold
SmartFTP.com

#3 dordal

dordal
  • Members
  • 2 posts

Posted 09 April 2003 - 05:33 AM

Thank you, that worked. Funny the FTP server didn't support that command when I typed it in manually, but if it works, it works. I'm happy.

It would be cool (in a future version) if you could set these preferences on a per-FTP-server basis.

#4 Louie

Louie
  • Members
  • 337 posts

Posted 09 April 2003 - 06:17 AM

It would be cool (in a future version) if you could set these preferences on a per-FTP-server basis.


This is already possible, but you will first need to add the site to your Favorites. Once the site is added, then
edit the favorite site, and in the "Properties > Advanced" section, set the listing options to your preference.

Please take a look at the following two KB articles as well:

http://www.smartftp....p?a=view&id=117

http://www.smartftp....p?a=view&id=118

If you got anymore questions, please don't hesitate to ask.