Jump to content


Photo

NAT support


  • Please log in to reply
2 replies to this topic

#1 jedimonkey

jedimonkey
  • Members
  • 1 posts

Posted 28 February 2003 - 03:57 PM

since downloading the latest upgrade (1.0.973) i've been unable to ftp to certain sites that rely on passive ftp. I am accessing the web through NAT and saw that the latest release 'enhanced' NAT Support.

Here is a log file of a non functioning FTP site:

Resolving host name ftp.dev.hollerdigital.co.uk...
Connecting to (ftp.dev.hollerdigital.co.uk).
Connected to (ftp.dev.hollerdigital.co.uk) -> IP: 213.171.193.5 PORT: 21.
Socket connected waiting for login sequence.
220 Matrix FTP Server ready.
USER ppp.pumpnshine.com
331 User name okay, need password.
PASS (hidden)
230 User logged in, proceed.
SYST
215 UNIX type: L8.
FEAT
502 Syntax error, command unrecognized.
REST 100
350 Requested file action pending further information.
REST 0
350 Requested file action pending further information.
PWD
257 "/ppp.pumpnshine.com" is is working directory.
TYPE A
200 Type set to A.
PASV
227 Entering Passive Mode (213,171,193,237,8,88).
Opening data connection IP: 213.171.193.5 PORT: 2136.
The operation completed successfully.
PORT 192,168,254,16,13,137
Connection closed. Server timeout.
Command aborted. Server timeout.

#2 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 01 March 2003 - 01:57 AM

Go to Settings->Connection and disable "Force Server IP for PASV mode"

-Mat

#3 fooo

fooo
  • Members
  • 1 posts

Posted 02 March 2003 - 11:28 PM

I have NEVER been able to upload files using SmartFTP to a certain site running Linux. I have tried active/passive, force/not force manual/automatic/default settings for the port. I can ALWAYS upload using windows FTP, but I can *never* upload with SmartFTP to a site I use (phpwebhosting.com).

I am behind a LinkSys internet gateway using NAT.
Session looks exactly the same as the user above:

200 Type set to I.
PASV
227 Entering Passive Mode (64,65,61,209,15,184).
Opening data connection IP: 64.65.61.209 PORT: 4024.
STOR NavSample.mov
150 Opening BINARY mode data connection for NavSample.mov
Connection closed. Server timeout.
The operation completed successfully.
226 Transfer complete.

here's a log with active (which I think is what windows FTP uses):
200 Type set to I.
PORT 192,168,0,3,4,15
200 PORT command successful.
Opening data connection IP: 192.168.0.3 PORT: 1039.
STOR NavSample.mov
150 Opening BINARY mode data connection for NavSample.mov.
Connection closed. Server timeout.
The operation completed successfully.
226 Transfer complete.



Here's windows ftp:
ftp> put INSTALL.LOG
---> PORT 192,168,0,3,19,52
200 PORT command successful.
---> STOR INSTALL.LOG
150 Opening BINARY mode data connection for INSTALL.LOG.
226 Transfer complete.
ftp: 2915 bytes sent in 0.03Seconds 97.17Kbytes/sec.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users