Jump to content


Photo

Queue bug - not obeying proxy settings


  • Please log in to reply
2 replies to this topic

#1 Rexxx

Rexxx
  • Members
  • 10 posts

Posted 21 February 2003 - 08:53 AM

Hi!

I work in a firewalled environment where I have to use SOCKS proxy to be able to access outside ftps. So my SmartFTP is set up to use one.

But there are few ftps on inner network that of course do not need to be accessed through proxy. When I connect to one of these ftps from a favorite everything is OK (because in that favorite properties the "Use proxy" checkbox is cleared)

However when I queue some download the global queue forgets about proxy settings and uses the global setting so it tries to access the ftp through SOCKS proxy which of course doesn't work.

Any plans to fix this? Thanx.

Rex

#2 Louie

Louie
  • Members
  • 337 posts
  • Gender:
    Male
  • Location:
    New York City

Posted 21 February 2003 - 09:06 AM

This is not a bug, the "Global Queue" just does not read any of the favorite settings, only the global settings.

The Global Queue follows the global settings, as Session Queue and Direct transfers read the favorite settings,
or even the Global settings, but only if you connect from the address bar field. Hope it's pretty clear for you now.

#3 Rexxx

Rexxx
  • Members
  • 10 posts

Posted 21 February 2003 - 10:08 AM

still that does not solve my problem. I would have to leave a session open to be able to download with the proxy settings derived from favorite entry which is at least a bit uncomfortable. I prefer to queue my downloads into global queue. OK, I'd have to live with it.

I'd like to say that I am really thankfull for the work you do - SmartFTP is in my eyes the greates FTP client... Thanx...

Rex




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users