Jump to content


Photo

Default System ftp Client


  • Please log in to reply
9 replies to this topic

#1 Mic

Mic
  • Members
  • 5 posts

Posted 08 February 2003 - 03:39 PM

Hello,
how can I make SmartFTP to the default ftp Client for all ftp:// commands?
WinXP

Can't find it.

Thanks.

#2 epp_b

epp_b
  • Members
  • 99 posts

Posted 09 February 2003 - 01:12 AM

Other than for HTTP, I don't think it is possible to have an application take over protocols for defaults.

Assuming you have WinXP SP1, you could go into the Add/Remove programs applet and see what default applications are available to set.

However, you can have SmartFTP running with the URL watcher enabled and copy FTP links to the clipboard to perform a similar action.

Forgive me if anyone out there knows of a way to set application defaults for Internet protocols.

You could make a feature suggesiton (ahem -- pardon me: Enhancement Request...) for a background application to load at startup that catches URL's with ftp protocols as you navigate to them.

#3 darix

darix
  • Members
  • 181 posts

Posted 09 February 2003 - 03:36 AM

start -> control panel -> folder options -> file types -> url: file transfer protocol -> advanced -> select action "open" -> edit :)

for a windows xp

should be similar on other windows version


darix

#4 Mic

Mic
  • Members
  • 5 posts

Posted 09 February 2003 - 10:23 AM

Thanks to you both.

@epp_b:
In "Add/Remove programs applet" is no option for ftp:// connections :lol:

I think it is possible, because my Opera do so. I registered Opera to be default Programm for ftp:// in Opera options. But now I want to have SmartFTP to do so ;) .

@darix
Nice idea, but in my "File Types" there is only "url: Internetconnection" and not file transfer protocol.



I have WinXP Pro SP1 and SmartFTP 1.0.973.

#5 epp_b

epp_b
  • Members
  • 99 posts

Posted 09 February 2003 - 02:52 PM

OK, maybe you were right ;)

I guess we learn something new every day!

#6 csant

csant
  • Members
  • 4 posts

Posted 10 February 2003 - 08:11 PM

@all

i am using win2000, german operating system - i don't know the proper english terms, but you can look for your match: the above path was not wrong at all:

in folderoptions > file names there are some files marked 'n.zutr' meaning not applicable (is there in the english system something like 'n.a.'?) and here you find all protocolls:

n.zutr. URL: CallTo Protocol
n.zutr. URL:FTP (File Transfer Protocol)
n.zutr. URL:Gopher

and so on. here you follow the rest of the above described path.

...but :?: it still does not work wth me!
there is an extended option asking weather to use DDE. if i leave it the way it is, all ftp:// are still done by IE, if i uncheck the DDE at my next browser start i get a prompt "IE is not your default browser". What now?

anybody with a clue :?:

csant.

#7 darix

darix
  • Members
  • 181 posts

Posted 10 February 2003 - 08:45 PM

DDE is not needed for smartftp.

anyway sorry. i replied with privmsg. i dont wanted my webspace url here. ;)

darix

#8 epp_b

epp_b
  • Members
  • 99 posts

Posted 11 February 2003 - 02:59 AM

Well, if I would have taken 30 seconds to take a look at the Windows folder options, I would have noticed that there are a bunch of Protocol file types, one of them being URL: File Transfer Protocol, that can easily be changed to SmartFTP from it's current state, Explorer.

So, YES, you CAN make SmartFTP your default FTP Client. I use Win98SE and it the file type is:

URL:File Transfer Protocol

#9 Mic

Mic
  • Members
  • 5 posts

Posted 11 February 2003 - 04:38 PM

Yes, thanks, I already discussed that with darix via PMSG ;)

#10 mb

mb

    Developer

  • Administrators
  • 11521 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 13 February 2003 - 09:01 PM

Hmm doesn't work for me on Windows 2000.

Anything special that needs to be changed?

-Mat




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users