Jump to content


Photo

APPE / STOR


  • Please log in to reply
2 replies to this topic

#1 SkyZ

SkyZ
  • Members
  • 2 posts

Posted 02 October 2002 - 06:10 AM

I have searched high & low in your forums, but I haven't found anything that answers my problem. I think other threads may have had the same problem I have, but the responses in those threads didn't help me (although one was interesting, regarding an old version of SmartFTP's using APPE instead of STOR, where, as you'll see below, it seems I need APPE instead of STOR).

So, here it is: I cannot resume on a particular Serv-U FTP server. I can upload a new file fine. I have been able to resume uploads on other servers, but I don't know offhand what the other ones were. From what I can tell, we are both behind routers, and I have to use Passive Mode in order to connect fully. I tried both SmartFTP 1.0.969.3 and the dev build 1.0.969.8. On this server's main upload account, I get "550 Permission Denied" when I try to resume an upload to it. I know. I know. The responses have always been in other threads, it's a server problem, not SmartFTP's problem. Well, that may or may not be true. Please keep reading.

SmartFTP uses "STOR" to upload files, including resumes. (Yes, I have tried both ASK and RESUME under the File Transfer options. Both give "550 Permission Denied". And with the ASK option, I don't get a dialog box.)

I loaded up WsFTP, and used APPEND FILE on the context menu for a local file, and it used "APPE" (after an expected PASV command), and the file resumed fine. If I used TRANSFER FILE, it used STOR and I got the same "550 Permission Denied" error as SmartFTP.

I tried to add "APPE" as a custom command (and even "PASV" followed by "APPE"), but got the dreaded :wink: "The command 'APPE' cannot be sent directly" message.

As a final note, I also tried an ADMIN account on this FTP server (which allows everything), and when I tried to resume an upload, the file on the server was overwritten by the file coming in (i.e. the file started uploading from the beginning). I was a little mad, but that's how these things go. I assume that since the ADMIN account has delete permission, the STOR command just deleted the original file and uploaded the file anew. This is probably why the upload resume didn't work on the normal UPLOAD account; with that account, I cannot delete files first.

So, to sum up, I cannot resume an upload using STOR on a particular Serv-U server, although I can upload a new file fine. SmartFTP doesn't seem to support using APPE (anymore, I saw in another thread that SmartFTP used to use APPE instead of STOR - see thread link below). Is it possible to add APPE as a custom command? Or to add an option like WsFTP to either Transfer a File (using STOR) *or* Append a File (using APPE). And why does STOR delete a file and start anew when I have delete permission? (I agree that this last problem is most likely due to a server issue with Serv-U, but I thought I'd ask in case someone knows.)

I switched to SmartFTP about 6 months ago when I needed to resume files en masse. Before that, I only used WsFTP. I love SmartFTP's interface and all the options it has, and haven't found any problems until now. I am hoping that APPE can be added quickly and easily. On a side note, a friend said that he finds SmartFTP lacking in only one feature: OverWrite if Newer (for updating web sites efficiently).

Ok. Here is my System Info:
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 1 (Build 2600)
CPU Speed : 1208 MHz
Total Memory : 523744 KB
Free Memory : 151644 KB
+- SmartFTP ---------------------------
Version : 1.0.969.8
+- Application DLL --------------------
Controls.dll : 1.6.969.8
Controls2.dll : 1.6.969.8
FTPAPI.dll : 2.0.969.8
Language.dll : 1.0.969.8
ResEng.dll : 1.3.969.8
+- System DLL -------------------------
shell32.dll : 6.00.2800.1106 (xpsp1.020828-1920)
shlwapi.dll : 6.00.2800.1106 (xpsp1.020828-1920)
comctl32.dll : 6.0 (xpsp1.020828-1920)
riched20.dll : 5.30.23.1211
msvcrt.dll : 7.0.2600.1106 (xpsp1.020828-1920)
msvcp60.dll : 6.00.8972.0
schannel.dll : 5.1.2600.1106 (xpsp1.020828-1920)
+- Internet Explorer ------------------
Version : 6.0.2800.1106
+- Winsock ----------------------------
Winsock : 2.2

And here's that other thread (Subj: STORE instead of APPE):
http://www.smartftp....&highlight=appe

Thank you for producing such a great FTP client. I'm sure it will keep getting better.

#2 mb

mb

    Developer

  • Administrators
  • 11520 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 October 2002 - 06:48 AM

APPE is used if your "Resume Rollback" setting in Settings->Transfer->Files is set to 0.

-Mat

#3 SkyZ

SkyZ
  • Members
  • 2 posts

Posted 02 October 2002 - 03:25 PM

Ok. I had it set for the default (0) at the very beginning (using 1.0.969.3), but it didn't work. I read through a bunch of threads, and decided to try a rollback > 0 (like 25 bytes). That didn't work. I now see that it was set to 25 bytes when I investigated thoroughly (and when I used 1.0.969.8 ) and saw the STOR command. I don't know what it did for rollback = 0 (i.e. if it used STOR or APPE).

Unfortunately, that FTP is down right now, and I never had problems with other FTPs, so I'm waiting for it to come back up again. Maybe I should have waited to post this reply, but I thought I'd mention that I had it set to 0 at the beginning, and it didn't work. (And I'm sure I tried it multiple times at 0, because I didn't know to change it until I read a thread here.)

Well, I'll let you know what command it uses when the rollback is 0. And if the upload resume works.

Thanks for the quick reply. I appreciate that. ;)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users