Jump to content


Photo

Edit File With (Select Program) - Bug?


Best Answer mb , 26 February 2014 - 08:35 PM

With the classic and modern UI mix Microsoft has created a usability nightmare in Windows 8.

Please install the latest version:
http://www.smartftp.com/download

Then I recommend that you add NPP to the editors in SmartFTP:
menu: Tools - Settings
Then go to the Remote Edit dialog and add Notepad++. Go to the full post


  • Please log in to reply
1 reply to this topic

#1 SmartBurger

SmartBurger
  • Members
  • 7 posts

Posted 26 February 2014 - 08:29 PM

I use Notepad++ (plus plus) to edit my PHP files.

 

I am unable to select Notepad++ as my default program when I right click to edit PHP files on the server view.

 

I am using Windows 8.

 

Here is how to reproduce the bug:

 

1)  Right click on PHP file in server view inside SmartFTP.  First problem:  Notepad++ is not listed.  Only Notepad.

2)  Select "Edit With...".   Again, Notepad++ is not listed.  Only Notepad.

3)  Select "Choose Default Program".

 

Here's where it gets really messy.

 

4)  Windows Dialoge pops up:  "How do you want to open this file?"  > Look for App in store?  / More options.  Click More Options.

5)  List of programs appear with a vertical scrollbar.  Scroll to bottom.  Click "Look for another App on this PC"

6)  File explorer dialogue pops up.  On top of that a windows popup that says:  "Server Busy.  This action cannot be completed because the other program is busy.  Choose "Switch To" to activate the busy program and correct the problem".

 

Selecting "Switch To" brings up the Windows 8 home screen.  Even if you select the appropriate program and it opens, SmartFTP is still stuck with this dialogue box up.  Nothing you do makes it go away.  Clicking switch to doesn't help.  Clicking Retry (the other button) doesn't do anything.  You can't close the windows file explorer showing beneath it either.  You can close all your programs and even force a close on SmartFTP ... but this thing stays on your screen.   No way to get it off the screen.   Must reboot computer entirely.

 

Bug?



#2 mb

mb

    Developer

  • Administrators
  • 11867 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 26 February 2014 - 08:35 PM   Best Answer

With the classic and modern UI mix Microsoft has created a usability nightmare in Windows 8.

Please install the latest version:
http://www.smartftp.com/download

Then I recommend that you add NPP to the editors in SmartFTP:
menu: Tools - Settings
Then go to the Remote Edit dialog and add Notepad++.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users