Jump to content


Photo

high memory consumption

high memory

Best Answer mb , 14 February 2014 - 12:56 PM

Close all the remote browsers:
menu: Window - Close All

With the remote browser closed, the browser cache is no longer maintained. Go to the full post


  • This topic is locked This topic is locked
5 replies to this topic

#1 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 11:31 AM

Hi,

I'm new to smartftp. Great application.

I'm facing two problems right now. For each I'm going to open new thread.

This thread is about the following issue.

 

#SETUP

Its a Windows SBS 2008 64bit Server. 24GB of RAM.

Fresh installed latest smartftp version.

 

Source: network path mapped as drive letter

Destination: remote FTP server

I have setup a scheduled sync with the option "One Way Synchronization with Delete"

This transfers/snycs round about 10Gb of files daily.

 

Since it is a new installation I have no experience regarding the resource hunger of smartftp.

After the latest run I have seen that smatrftp comsumed 17GB (yes gigabytes). so I closed it. reopened it again.

tonight it synced again round about 6GB (queue stucked due to the delete error > see other thread), I removed the stuck elements.

Now it's already at 800MB memory usage.

 

17Gb is way to much, but also 800MB seems pretty much for me. What can be done here?

 

Thanks


Edited by BruceLee, 14 February 2014 - 11:31 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11874 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 February 2014 - 12:56 PM   Best Answer

Close all the remote browsers:
menu: Window - Close All

With the remote browser closed, the browser cache is no longer maintained.

#3 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 02:11 PM

no other way to disable browser cache? I like having the interface open to have a quick look.

 

also one question about the solution: I closed all windows. memory consumption stays the same. so no memory changes at all.

Thanks



#4 mb

mb

    Developer

  • Administrators
  • 11874 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 February 2014 - 04:09 PM

You can still open a browser, but close it afterwards.

>so no memory changes at all.
Maybe there is a still a reference to the cache. Restarting SmartFTP will purge the session cache. So that is something you can try.

#5 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 04:50 PM

obviuosly after restarting it went down to 50MB. I will monitor it over the next days and see how it looks like after a few transfers if its increasing without browser windows as well. I will give a reply soon. thanks



#6 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 16 February 2014 - 08:36 AM

After a couple of transfers memory consumption is still at ~60MB. Perfect.

Thanks






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users