Jump to content


Photo

queue stuck at 'delete' of non existing files in scheduled sync

schedule queue delete sync

  • Please log in to reply
7 replies to this topic

#1 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 11:16 AM

Hi,

I'm new to smartftp. Great application.

I'm facing two problems right now. For each I'm going to open new thread.

This thread is about the following issue.

 

#SETUP

Source: network path mapped as drive letter

Destination: remote FTP server

I have setup a scheduled sync with the option "One Way Synchronization with Delete"

the favorite (ftp server = destination) also has an include filter that is based on patterns like *-cd.md5, *-cd.spi

This is becuase I only want to transfer and snyc certain files that are created dynamically by a backup application. 
Now the schedule is starting the sync process. All needed files get transfered but.....

 

smartftp is trying to delete files on destination that have been deleted only on source by another process (due to consolidation). those files are never synced because they do not match the include filter.

so there is nothing to delete regarding these files. but there are other files that need to be deleted and match the include filter pattern.

 

How to avoid that smartftp is trying to delete files that have never been on destination and were deleted only on source?
I want to the sync to run trough without errors.
Thanks


Edited by BruceLee, 14 February 2014 - 11:32 AM.


#2 mb

mb

    Developer

  • Administrators
  • 11874 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 February 2014 - 12:46 PM

1. Change the synchronization from "One Way Synchronization with Delete" to "One Way Synchronization"
2. Change the operation from Copy to Move
3. In the Advanced dialog in the transfer queue item properties, enable the "Keep Folder" option.

#3 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 02:07 PM

1. Change the synchronization from "One Way Synchronization with Delete" to "One Way Synchronization"

 

?That confuses me. Like I wrote I need smartftp to delete files on destination that are no longer in source. It's just that the files that are not on destination do not need to be deleted since they are not there.

 

2. Change the operation from Copy to Move

 

I need the files on both, source an destination. thats why I setup the sync. I don't see how this can help.
 

3. In the Advanced dialog in the transfer queue item properties, enable the "Keep Folder" option.

 

What does it do? The problem is with files only. No folders are created/deleted at all.

 

the question is why is smartftp assuming that files need to be deleted when they are not there?

Thanks.



#4 mb

mb

    Developer

  • Administrators
  • 11874 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 February 2014 - 04:11 PM

I see the problem now. Can you post a transfer log from a file SmartFTP is trying to delete on the destination?

#5 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 04:47 PM

yes, definitely. I will have to post it tomorrow because after I delete the stuck entries from queue it can only be reproduced when real files are deleted from source.  therefore I need to wait until the consolidation ran through.

thanks



#6 mb

mb

    Developer

  • Administrators
  • 11874 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 February 2014 - 05:50 PM

I have identified the problem now. Updates coming soon.

#7 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 14 February 2014 - 06:15 PM

your post was empty.

I created a testfile, run sync, nothing synced since it does not match include filter, deleted it, synced again and now I got it in the queue stucked. Thats the way to reproduce the error. the transfer log shows only this:

[19:12:16] Initializing. Transfer Queue v5.0.1349.0.
[19:12:16] Operation Begin
[19:12:16] CWD /SRV-NAS02-Sync/ShadowProtect-Backups/\SRV-DC01
[19:12:16] 550 /SRV-NAS02-Sync/ShadowProtect-Backups/\SRV-DC01: No such file or directory
[19:12:16] Operation End

 

/SRV-NAS02-Sync/ShadowProtect-Backups/\SRV-DC01 is the destination directory
thanks


Edited by BruceLee, 14 February 2014 - 06:26 PM.


#8 BruceLee

BruceLee
  • Members
  • 9 posts

Posted 15 February 2014 - 11:59 AM

Thanks to the developers excellent work he identified the problem, coded and patched it and released a new version 5.0.1351.0.

Problem is solved.

Thanks a lot.

A remarkable support.







Also tagged with one or more of these keywords: schedule, queue, delete, sync

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users