Jump to content


Photo

Special Characters - Transfer Fails


  • Please log in to reply
6 replies to this topic

#1 Wasabi Ice Cream

Wasabi Ice Cream
  • Members
  • 4 posts
  • Gender:
    Male

Posted 14 January 2013 - 05:41 PM

As the topic title says, when a filename contains a special character, (Accented or foreign characters) file transfer just fails.

I'm not sure how to solve this, and any help will be appreciated.

Using SmartFTP v4.0.1245.0. Thanks in advence!



#2 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 January 2013 - 09:51 PM

Install the latest version. Then post the complete log with the error here.

#3 Wasabi Ice Cream

Wasabi Ice Cream
  • Members
  • 4 posts
  • Gender:
    Male

Posted 15 January 2013 - 10:58 AM

Thanks for the quick reply.

The thing is, no error is ever returned.

The transfer just gets caught in a "Retry" loop.

The special character is this case is an "×".

Even trying to expand the folder with that character in it doesn't work.

Also, I don't want to rename the files.

 

[11:53:15] SmartFTP v4.1.1291.0
[11:53:18] Resolving host name "nexus.underleech.org"
[11:53:18] Connecting to 91.121.23.83 Port: 21001
[11:53:18] Connected to nexus.underleech.org.
[11:53:18] 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
[11:53:18] 220-You are user number 2 of 25 allowed.
[11:53:18] 220-Local time is now 14:53. Server port: 21001.
[11:53:18] 220-This is a private system - No anonymous login
[11:53:18] 220-IPv6 connections are also welcome on this server.
[11:53:18] 220 You will be disconnected after 15 minutes of inactivity.
[11:53:18] AUTH TLS
[11:53:18] 234 AUTH TLS OK.
[11:53:18] TLS 1.0 encrypted session established.
[11:53:18] Key Exchange: 1024 bit RSA
[11:53:18] Session Cipher: 128 bit AES
[11:53:18] Command channel protection set to Private.
[11:53:18] PBSZ 0
[11:53:18] 200 PBSZ=0
[11:53:18] USER nexus1040
[11:53:18] 331 User nexus1040 OK. Password required
[11:53:18] PASS (hidden)
[11:53:18] 230-This server supports FXP transfers
[11:53:18] 230 OK. Current restricted directory is /
[11:53:18] SYST
[11:53:18] 215 UNIX Type: L8
[11:53:18] Detected Server Type: UNIX
[11:53:18] RTT: 24.881 ms
[11:53:18] FEAT
[11:53:18] 211-Extensions supported:
[11:53:18]  EPRT
[11:53:18]  IDLE
[11:53:18]  MDTM
[11:53:18]  SIZE
[11:53:18]  MFMT
[11:53:18]  REST STREAM
[11:53:18]  MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[11:53:18]  MLSD
[11:53:18]  AUTH TLS
[11:53:18]  PBSZ
[11:53:18]  PROT
[11:53:18]  TVFS
[11:53:18]  ESTA
[11:53:18]  PASV
[11:53:18]  EPSV
[11:53:18]  SPSV
[11:53:18] 211 End.
[11:53:18] Detected Server Software: PureFTPd
[11:53:18] PWD
[11:53:18] 257 "/" is your current location
[11:53:18] CWD /downloads
[11:53:18] 250 OK. Current directory is /downloads
[11:53:18] PWD
[11:53:18] 257 "/downloads" is your current location
[11:53:18] TYPE A
[11:53:18] 200 TYPE is now ASCII
[11:53:18] PROT P
[11:53:18] 200 Data protection level set to "private"
[11:53:18] PASV
[11:53:18] 227 Entering Passive Mode (91,121,23,83,82,28)
[11:53:18] Opening data connection to 91.121.23.83 Port: 21020
[11:53:18] MLSD
[11:53:18] 150 Accepted data connection
[11:53:18] 226-Options: -a -l 
[11:53:18] 226 106 matches total
[11:53:18] 15542 bytes transferred. (119 KB/s) (127 ms)


#4 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 15 January 2013 - 09:43 PM

Post the complete transfer log.

#5 Wasabi Ice Cream

Wasabi Ice Cream
  • Members
  • 4 posts
  • Gender:
    Male

Posted 15 January 2013 - 09:57 PM

[22:53:39] Operation Begin
[22:53:39] CWD /downloads/[Coalgirls]_Kampfer_(1920×1080_Blu-Ray_FLAC)
[22:53:39] 550 Can't change directory to /downloads/[Coalgirls]_Kampfer_(1920×1080_Blu-Ray_FLAC): No such file or directory
[22:53:39] Transfer failed.
[22:53:39] Operation End
[22:54:09] Operation Begin
[22:54:09] CWD /downloads/[Coalgirls]_Kampfer_(1920×1080_Blu-Ray_FLAC)
[22:54:10] 550 Can't change directory to /downloads/[Coalgirls]_Kampfer_(1920×1080_Blu-Ray_FLAC): No such file or directory
[22:54:10] Transfer failed.
[22:54:10] Operation End


#6 mb

mb

    Developer

  • Administrators
  • 11528 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 15 January 2013 - 10:21 PM

The server does not support UTF8. You need to set the correct codepage manually in the favorite properties:
FTP-Transfer page
Code Page option

#7 Wasabi Ice Cream

Wasabi Ice Cream
  • Members
  • 4 posts
  • Gender:
    Male

Posted 15 January 2013 - 11:25 PM

Awesome! That solved it.

Thanks for the help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users