Jump to content


Photo

Cannot install latest version 'sfFTPLib.dll is not registered correctly' 4.1.1263.0


  • Please log in to reply
8 replies to this topic

#1 nicw

nicw
  • Members
  • 12 posts

Posted 01 September 2012 - 07:41 PM

Licensed user here. I have downloaded the latest version 4.1.1263.0 (64bit) to my Windows 7 machine. After install, I try to run it and I get the error 'sfFTPLib.dll is not registered correctly'. This is a fresh windows 7 install

I have:
1) Rebooted the computer
2) Redownloaded the file
3) Remove the previous installation
4) Reinstalled
5) I get the same error

I also tried the 32bit version but got an install error that I had selected the wrong type.

I tried to contact support, but the KB link says I have to request within the program......which won't run.......

#2 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 01 September 2012 - 08:07 PM

Maybe your software firewall or registry cleaner is causing the problem?

#3 nicw

nicw
  • Members
  • 12 posts

Posted 01 September 2012 - 08:46 PM

This is a brand-new install. This is the *first* application to be installed. I turned off Windows Firewall to double-check, still getting the same error.

I also tried reinstalling, and selecting the 'Repair' option, rebooting and trying again. This is very frustrating.

#4 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 02 September 2012 - 10:18 AM

Do you have the SP1 for Windows 7 installed?

Open a command line as admin, go to the SmartFTP program files folder, then enter regsvr32 sfFTPLib.dll

#5 nicw

nicw
  • Members
  • 12 posts

Posted 02 September 2012 - 08:13 PM

Yes, I am running Windows 7 Enterprise, SP1. I typed that command, and I got the following error:
"The module 'sfFTPLib.dll' failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. Invalid access to memory location"

To confirm I had the right file, I tried the same command outside the SmartFTP directory, and got the same error message, except the bolded part above now said "The specified module could not be found". So it's finding the module, but the module is trying to access somewhere in memory it isn't allowed to.

#6 nicw

nicw
  • Members
  • 12 posts

Posted 17 October 2012 - 04:25 AM

I'm still unable to install this, has anyone else encountered this issue? I'm using CuteFTP as an alternative, but since I bought a three year license to SmartFTP I want to make the most of it - or get a refund.

#7 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 17 October 2012 - 04:51 AM

Please contact support:
https://www.smartftp...port-f2653.html

#8 nicw

nicw
  • Members
  • 12 posts

Posted 22 October 2012 - 01:36 AM

Please contact support:
https://www.smartftp...port-f2653.html


Sorry, the only way to request technical support is within the program - which I can't install! I mentioned this in the first line of my post.

#9 mb

mb

    Developer

  • Administrators
  • 11527 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 22 October 2012 - 12:15 PM

Try to install SmartFTP on a different computer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users