Jump to content


Editing remote file uses cached version NOT server

  • Please log in to reply
2 replies to this topic

#1 BrinK

  • Members
  • 8 posts
  • Location:

Posted 31 August 2012 - 12:30 PM

When I right click edit on a remote file, it opens that file in the SmartFTP editor window.

The problem is, the version that is loading into the editor is NOT the server side version. I presume some form of caching is causing havoc here. This is really bad, a colleague edited a file on the server, then I edited it again and completely overwrote all his changes with my cached copy. Very bad!

Could this please be looked into? Why is it being cached? It should be downloading a fresh copy EVERY time I right click edit on the file.

I just updated to the latest version and it's still happening. Windows 7 x64.

Sorry about posting this in the wrong section. Just seen bug reports and posted away without realising it was for the Library.

Edited by BrinK, 31 August 2012 - 12:31 PM.

#2 mb



  • Administrators
  • 11894 posts
  • Gender:
  • Location:

Posted 31 August 2012 - 03:31 PM

In the menu: Tools->Settings, in the General - Remote Edit page there is an option [x] Always overwrite local file. Enable it and try it again.

#3 BrinK

  • Members
  • 8 posts
  • Location:

Posted 01 September 2012 - 12:00 AM

Thanks mb! Will enable that and see how I go.

Is there any reason why this isn't on by default? Considering the disastrous effects it can have.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users