Jump to content


Photo

Enter custom command


  • Please log in to reply
12 replies to this topic

#1 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 06 March 2012 - 12:53 AM

Is there a way to execute custom command on smart FTP ?

Like on filezilla (Server > Enter custom command)

Thank

#2 mb

mb

    Developer

  • Administrators
  • 11526 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 06 March 2012 - 01:55 AM

menu: View->Toolsbars->Command Line

#3 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 07 March 2012 - 11:11 PM

Ok, but..

This option only appear when my smartftp language is set to "english".
When smartftp is set to my default windows language (french), this option does not appear in the menu.

And even if i checked it when smartftp is in english, if i restart it in french, the command line bar disappear.

Edited by Le Loup, 07 March 2012 - 11:12 PM.


#4 mb

mb

    Developer

  • Administrators
  • 11526 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 08 March 2012 - 02:14 AM

Post the system information from the menu: Help->About System Information dialog.

#5 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 10 March 2012 - 12:43 AM

+- System -----------------------------
Microsoft Windows 7 Ultimate Edition
Service Pack 1 (Build 7601)

CPU Speed : 2004 MHz
Total Memory : 3071 MB
Free Memory : 1126 MB

+- SmartFTP ---------------------------
Version : 4.0.1236.0
Time Stamp : 2012-02-23 22:57:09
Platform : x64
Id : 400054903
Maintenance : 2012-09-22
Days in use : 266

+- Language ---------------------------
fr-FR

+- Internet Explorer ------------------
Version : 9.0.8112.16421



#6 mb

mb

    Developer

  • Administrators
  • 11526 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 10 March 2012 - 08:46 AM

I'm unable to reproduce the problem. This is what I did:
1. Installed French addon
2. Started SmartFTP
3. Enabled the command line in the View menu

Try to reset the registry keys:
https://www.smartftp...ings-f2625.html

Then start SmartFTP, select French, restart. And then enable the command line.

#7 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 14 March 2012 - 12:30 AM

I reset registry keys but now, Command line disappears from both french and english
I tried to update smartftp to the latest version. But the problem still be...

Posted Image

#8 mb

mb

    Developer

  • Administrators
  • 11526 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 14 March 2012 - 12:52 AM

Are you using the FTP/FTPS protocol? The command line is only available for these protocols.

#9 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 14 March 2012 - 04:14 PM

Yes it's FTP protocol.

Today, Command line option is back in english and french.
Very strange...

#10 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 14 March 2012 - 04:17 PM

I think i found what happen.

Maybe the focused window was my local folder on the right.
When the focus is on the local folder windows, the option doesn't appear.

(On the picture in the title bar, we can see 'Favorites' witch is my local window focused in smartftp)

Edited by Le Loup, 14 March 2012 - 04:19 PM.


#11 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 22 March 2012 - 03:45 PM

Hello,

Today, I needed to enter a custom command on my FTP in order to "unlock" a website blocked by my host :

SITE CHMOD 705 /

When I enter it with smartFTP :

[16:37:04] SITE CHMOD 705 /
[16:37:04] 200 Permissions changed on /

But my website still blocked


When I enter it with Filezilla :

Command: SITE CHMOD 705 /
Response: 200 Permissions changed on /

website is now available

Why ?

#12 mb

mb

    Developer

  • Administrators
  • 11526 posts
  • Gender:
    Male
  • Location:
    Worldwide

Posted 22 March 2012 - 04:16 PM

I will ask my crystal ball and get back to you.

#13 Le Loup

Le Loup
  • Members
  • 15 posts

Posted 17 September 2012 - 04:48 PM

I juste discover the solution.

A space is needed after the /




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users